[POJ2104][SPOJ3946] K-th Number

传送门

POJ2104

SPOJ3946

Description

You are working for Macrohard company in data structures department. After failing your previous task about key insertion you were asked to write a new data structure that would be able to return quickly k-th order statistics in the array segment.
That is, given an array a[1…n] of different integer numbers, your program must answer a series of questions Q(i, j, k) in the form: “What would be the k-th number in a[i…j] segment, if this segment was sorted?”
For example, consider the array a = (1, 5, 2, 6, 3, 7, 4). Let the question be Q(2, 5, 3). The segment a[2…5] is (5, 2, 6, 3). If we sort this segment, we get (2, 3, 5, 6), the third number is 5, and therefore the answer to the question is 5.

Input

The first line of the input file contains n — the size of the array, and m — the number of questions to answer (1 <= n <= 100 000, 1 <= m <= 5 000).
The second line contains n different integer numbers not exceeding 109 by their absolute values — the array for which the answers should be given.
The following m lines contain question descriptions, each description consists of three numbers: i, j, and k (1 <= i <= j <= n, 1 <= k <= j - i + 1) and represents the question Q(i, j, k).

Output

For each question output the answer to it — the k-th number in sorted a[i…j] segment.

Sample Input

7 3
1 5 2 6 3 7 4
2 5 3
4 4 1
1 7 3

Sample Output

5
6
3

Hint

This problem has huge input,so please use c-style input(scanf,printf),or you may got time limit exceed.

Solution

  • 简单的单询问可以用权值线段树解决
  • 多次询问不同区间,想到了前缀和….对于每个[1,i]区间,建一颗权值线段树。由于数值范围很大,大概是要动态开点
  • 询问[l,r]区间时,将第r棵与第l-1棵相减,即得到了该区间的权值线段树,然后与单询问无异
  • 瞎扯了这么多,其实就是个简单的可持久化线段树。

Code

#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>
using namespace std;
int n,m,b[100007],a[100007],hash[100007];
int sz;
struct JOKER{
    int rt,ls,rs,s;
}tree[8000007];
bool cmp(int a,int b){
    return a<b;
}
void insert(int l,int r,int x,int &y,int v){
    y=++sz;
    tree[y].s=tree[x].s+1;
    if (l==r) return;
    tree[y].ls=tree[x].ls; tree[y].rs=tree[x].rs;
    int mid=(l+r)>>1;
    if (v<=mid) insert(l,mid,tree[x].ls,tree[y].ls,v);
        else insert(mid+1,r,tree[x].rs,tree[y].rs,v);
}
int query(int l,int r,int x,int y,int k){
    //printf("k=%d\n",k);
    if (l==r) return l;
    int mid=(l+r)>>1;
    int ly=tree[y].ls,lx=tree[x].ls;
    int delta=tree[ly].s-tree[lx].s;
    if (delta>=k) return query(l,mid,tree[x].ls,tree[y].ls,k);
        else return query(mid+1,r,tree[x].rs,tree[y].rs,k-delta);
}
int main(){
    scanf("%d%d",&n,&m);
    for (int i=1;i<=n;i++){scanf("%d",&a[i]); b[i]=a[i];}

    sort(b+1,b+n+1,cmp);
    int N=1; hash[1]=b[1];
    for (int i=2;i<=n;i++)
        if (b[i]!=b[i-1]) hash[++N]=b[i];
    //for (int i=1;i<=N;i++) printf("%d ",hash[i]); printf("\n");

    for (int i=1;i<=n;i++){
        int l=1,r=N,ans=0,x=a[i];
        while (l<=r){
            int mid=(l+r)>>1;
            if (x==hash[mid]){ans=mid; break;}
            if (x>hash[mid]) l=mid+1; else r=mid-1;
        }
        a[i]=ans;
    }
    //for (int i=1;i<=N;i++) printf("%d ",a[i]); printf("\n");
    for (int i=1;i<=n;i++)
        insert(1,N,tree[i-1].rt,tree[i].rt,a[i]);

    for (int i=1;i<=m;i++){
        int l,r,v;
        scanf("%d%d%d",&l,&r,&v);
        int ans=query(1,N,tree[l-1].rt,tree[r].rt,v);
        printf("%d\n",hash[ans]);
    }
    //printf("sz=%d\n",sz);
    return 0;
}
//POJ2104
//SPOJ3946
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值