1.6 [hduoj] 2053 Switch Game

Problem Description

There are many lamps in a line. All of them are off at first. A series of operations are carried out on these lamps. On the i-th operation, the lamps whose numbers are the multiple of i change the condition ( on to off and off to on ).

Input

Each test case contains only a number n ( 0< n<= 10^5) in a line.

Output

Output the condition of the n-th lamp after infinity operations ( 0 - off, 1 - on ).

Sample Input

1

5

Sample Output

1

0

Hint

hint Consider the second test case:

The initial condition : 0 0 0 0 0 …

After the first operation : 1 1 1 1 1 …

After the second operation : 1 0 1 0 1 …

After the third operation : 1 0 0 0 1 …

After the fourth operation : 1 0 0 1 1 …

After the fifth operation : 1 0 0 1 0 …

The later operations cannot change the condition of the fifth lamp any more. So the answer is 0.

#include<stdio.h>
#include<math.h>
void main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        int cnt=0;
        if(n==1)
            printf("%d\n",1);
        else
        {
            for(int i=2;i<sqrt(n)+1;i++)
            {
                if(n%i==0&&n/i==i)
                    cnt++;
                if(n%i==0&&n/i!=i)
                    cnt+=2;
            }
            if(cnt%2==1)
                printf("%d\n",1);
            else
                printf("%d\n",0);
        }
    }
}

题目的意思就是输入一个数n表示有n个台灯(其实前面n-1个全是摆设),每次在n的因数的时候就改变一下第n个台灯的开关状态,到第n次以后台灯就不会改变状态了(因为比n大的都不是n的因数。)其实就是求n从1到n有几个因数,奇数个的话最后状态就是1,偶数个的话最后状态就是0.

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值