hdoj2053Switch Game

3 篇文章 0 订阅
Problem Description
There are many lamps in a line. All of them are off at first. A series of operations are carried out on these lamps. On the i-th operation, the lamps whose numbers are the multiple of i change the condition ( on to off and off to on ).
 

Input
Each test case contains only a number n ( 0< n<= 10^5) in a line.
 

Output
Output the condition of the n-th lamp after infinity operations ( 0 - off, 1 - on ).
 

Sample Input
  
  
1 5
 

Sample Output
  
  
1 0
Hint
hint
Consider the second test case: The initial condition : 0 0 0 0 0 … After the first operation : 1 1 1 1 1 … After the second operation : 1 0 1 0 1 … After the third operation : 1 0 0 0 1 … After the fourth operation : 1 0 0 1 1 … After the fifth operation : 1 0 0 1 0 …

The later operations cannot change the condition of the fifth lamp any more. So the answer is 0.

代码:

#include<cstdio>
#include<cmath>
int main()
{
    int n,k;
    while(~scanf("%d",&n)){
        k=sqrt(n);
        if(k*k==n)printf("1\n");
        else printf("0\n");
    }
    return 0;
}
 

思路:这道题用笨办法,写来写去老是超时,没有抓住规律,然后看了看大神的代码,就是这么简便又任性!!

解题思路:如果是完全平方数,就是1,其他的就是0。因为如果是完全平方数的话,1的时候必变,所以sum=1开始算,平方根变一下,自己在变一下,所以sum=1。(至于平方根,往前推就对了)

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值