2.1 PAT 甲级 1002 A+B for Polynomials

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ ... N​K​​ a​N​K​​​​

where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2
#include<stdio.h>
int n,k;
double nk;
double num[2][1001];
int main()
{
    for(int i=0;i<=1000;i++)
    {
        num[0][i]=i;
        num[1][i]=0;
    }
    int cnt=0;
    for(int j=0;j<2;j++)
    {
        scanf("%d",&n);
        while(n--)
        {
            scanf("%d%lf",&k,&nk);
            num[1][k]+=nk;
        }
    }
    for(int i=1000;i>=0;i--)
        if(num[1][i])
            cnt++;
    printf("%d",cnt);
    for(int i=1000;i>=0;i--)
        if(num[1][i])
            printf(" %d %.1f",i,num[1][i]);
    return 0;
}

这题理解题意的时候其实用了挺久的,后来发现就算多项式里相同指数的系数相加。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值