一、题目
This time, you are supposed to find A+B where A and B are two polynomials.
Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:
K N1 aN1 N2 aN2 ... NK aNK
where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤NK<⋯<N2<N1≤1000.
Output Specification:
For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.
Sample Input:
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output:
3 2 1.5 1 2.9 0 3.2
二、题目大意
多项式加法
三、考点
模拟、数组
四、解题思路
1、使用 float 数组保存系数,指数作为数组下标
2、读取数据,并将指数对应的数据累加
3、最终输出的时候,要指数从大到小,所以要从后往前遍历
4、读取、计数和输出操作可以写在一个循环里,也可以分开。写在一起,节省运行时间;分开写的话,思路更加清晰,减少出错概率。
五、代码
#include<iostream>
#include<string>
#define N 1010
using namespace std;
int main() {
float ans[N];
fill(ans, ans + N, 0.0);
//读取数据
int n;
cin >> n;
while (n--) {
int a;
float f;
cin >> a >> f;
ans[a] += f;
}
cin >> n;
while (n--) {
int a;
float f;
cin >> a >> f;
ans[a] += f;
}
//计算非0的个数
int cnt = 0;
for (int i = 0; i < N; ++i)
if (ans[i] != 0)
cnt++;
//输出,从大往小输出
cout << cnt;
for (int i = N - 1; i >= 0; --i)
if (ans[i] != 0)
printf(" %d %.1f", i, ans[i]);
system("pause");
return 0;
}