4.9 PAT 甲级 1015 Reversible Primes

reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (<10​5​​) and D (1<D≤10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line Yes if N is a reversible prime with radix D, or No if not.

Sample Input:

73 10
23 2
23 10
-2

Sample Output:

Yes
Yes
No
#include<iostream>
#include<vector>
#include<math.h>
using namespace std;

typedef long long LL;

bool is_prime(LL t)
{
    if(t==2||t==3)
        return true;
    if((t%6!=1&&t%6!=5)||t==1)
        return false;
    for(int i=5;i<sqrt(t);i+=6)
        if(t%i==0||t%(i+2)==0)
            return false;
    return true;
}

//其他进制转化成十进制
LL turn_decimal(vector<int> &a,int r)
{
    LL res=0;
    for(auto x:a)
        res=res*r+x;
    cout<<res<<endl;
    return res;
}

//十进制转化成其他进制并逆置
vector<int> decimal_others(LL a,int r)
{
    vector<int>b;
    while(a)
    {
        b.push_back(a%r);
        a/=r;
    }
    return b;
}

int main()
{
    int d,n;
    while(cin>>n>>d)
    {
        if(n<0)
            return 0;
        //首先将输入的数转化成相应进制后存入vector
        vector<int>a=decimal_others(n,d);

        //计算逆置后的数转化成十进制后的值
        LL rn=turn_decimal(a,d);

        //判断两个数是不是都是质数
        if(is_prime(n)&&is_prime(rn))
            cout<<"Yes"<<endl;
        else
            cout<<"No"<<endl;
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值