pat 甲级 1015 Reversible Primes

reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (<105) and D (1<D≤10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line Yes if N is a reversible prime with radix D, or No if not.

Sample Input:

73 10
23 2
23 10
-2

Sample Output:

Yes
Yes
No

题意:反转素数,输入两个数,第一个数判断是不是素数,第二个数是该数要转换的进制,将第一个数转换成该进制后再逆序转换成10进制,判断这个十进制数是否为素数,如果转换前和转换后都是素数,输出yes,否则输出no,第一个数是负数时,推出循环;

举个栗子:

72 10,73转换成10进制,再逆序转换成10进制,就是37,任为素数,输出Yes

23 2,23是素数,转换成2进制为11101,反转后为10111,转换成10进制数为29,还是素数,输出Yes

代码:
 

#include<iostream>
#include<cmath>
using namespace std;
bool isprime(int num){
    if(num<=1)return false;
	int sqr=(int )sqrt(1.0*num);
	for(int i=2;i<=sqr;i++){
		if(num%i==0){
			return false;
		} 
	}
	return true;
}
int convert(int num,int radix){
	int a[111]={0};
	int len=0;
	do{
		a[len++]=num%radix;
		num/=radix;
	}while(num!=0);//转换成radix进制数;
	for(int i=0;i<len;i++){//因为存在a数组的时候就是逆序从个位开始存储的,所以遍历从0开始就是逆序遍历了,就可以得到其反转数;
		num=num*radix+a[i];//因为每存储一位是除以radix,所以乘以radix再加上余数就是这个位的十进制值;
	}
	return num;
}
int main(){
	int num,radix;
	while(scanf("%d",&num)!=EOF){
		if(num<0)break;
        cin>>radix;
		if(isprime(num)==false){
            cout<<"No"<<"\n";
            continue;
        }
		int  n=convert(num,radix);
		isprime(n)==true?cout<<"Yes"<<"\n":cout<<"No"<<"\n";
	}
	return 0;
}

收获:
10进制数转换成n进制数;

do{
    a[len++]=num%radix;
    num/=radix;
}while(num!=0);

n进制数转换成10进制数:
 

for(int len-1;i>=0;i++){
    num=num*radix+a[i];
}

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值