4.9 PAT 甲级 1027 Colors in Mars

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input Specification:

Each input file contains one test case which occupies a line containing the three decimal color values.

Output Specification:

For each test case you should output the Mars RGB value in the following format: first output #, then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a 0 to its left.

Sample Input:

15 43 71

Sample Output:

#123456
#include<iostream>

using namespace std;

char s[13]={'0','1','2','3','4','5','6','7','8','9','A','B','C'};
string turn(int n)
{
    string t;
    while(n)
    {
        t=s[n%13]+t;
        n/=13;
    }
    if(t.size()==1)
        t='0'+t;
    if(t.size()==0)
        t="00";
    return t;
}

int main()
{
    int a,b,c;
    cin>>a>>b>>c;
    cout<<'#';

    //分别把这三个数转化成十三进制数
    cout<<turn(a)<<turn(b)<<turn(c)<<endl;
    return 0;
}

就是把输入的三个十进制数转化成十三进制数

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值