9.9 PAT 1065 A+B and C (64bit)

Given three integers A, B and C in [−2​63​​,2​63​​], you are supposed to tell whether A+B>C.

Input Specification:

The first line of the input gives the positive number of test cases, T (≤10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:

For each test case, output in one line Case #X: true if A+B>C, or Case #X: false otherwise, where X is the case number (starting from 1).

Sample Input:

3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0

Sample Output:

Case #1: false
Case #2: true
Case #3: false
#include<iostream>

using namespace std;

typedef long long int ll;
int t;
ll a, b, c;

bool check(ll a, ll b, ll c)
{
    ll d = a + b;
    if(a >= 0 && b >= 0 && d < 0) return true;
    if(a < 0 && b < 0 && d >= 0) return false;
    
    return a + b > c;
}

int main()
{
    cin >> t;
    for(int i = 1; i <= t; i ++ )
    {
        printf("Case #%d: ", i);
        scanf("%lld%lld%lld", &a, &b, &c);
        if(check(a, b, c))
            printf("true\n");
        else
            printf("false\n");
    }
    
    
}

long long int 可以存下64位的数据,但是因为计算机计算加法的时候用的是补码,所以计算出来的结果可能会溢出,当两个数都位正数时,溢出结果为负,但是因为三个数都是64位以内,所以当两个正数相加溢出(判断结果为相加结果为负)时,a+b>c一定成立,相反,如果两个负数相加溢出,结果不成立。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值