hdu6143 排列

Killer Names

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 639    Accepted Submission(s): 312


Problem Description
> Galen Marek, codenamed Starkiller, was a male Human apprentice of the Sith Lord Darth Vader. A powerful Force-user who lived during the era of the Galactic Empire, Marek originated from the Wookiee home planet of Kashyyyk as the sole offspring of two Jedi Knights—Mallie and Kento Marek—who deserted the Jedi Order during the Clone Wars. Following the death of his mother, the young Marek's father was killed in battle by Darth Vader. Though only a child, Marek possessed an exceptionally strong connection to the Force that the Dark Lord of the Sith sought to exploit.
>
> When Marek died in 2 BBY, shortly after the formation of the Alliance, Vader endeavored to recreate his disciple by utilizing the cloning technologies of the planet Kamino. The accelerated cloning process—an enhanced version of the Kaminoan method which allowed for a rapid growth rate within its subjects—was initially imperfect and many clones were too unstable to take Marek's place as the Dark Lord's new apprentice. After months of failure, one particular clone impressed Vader enough for him to hope that this version might become the first success. But as with the others, he inherited Marek's power and skills at the cost of receiving his emotions as well, a side effect of memory flashes used in the training process.
>
> — Wookieepedia

Darth Vader is finally able to stably clone the most powerful soilder in the galaxy: the Starkiller. It is the time of the final strike to destroy the Jedi remnants hidden in every corner of the galaxy.

However, as the clone army is growing, giving them names becomes a trouble. A clone of Starkiller will be given a two-word name, a first name and a last name. Both the first name and the last name have exactly  n  characters, while each character is chosen from an alphabet of size  m . It appears that there are  m2n  possible names to be used.

Though the clone process succeeded, the moods of Starkiller clones seem not quite stable. Once an unsatisfactory name is given, a clone will become unstable and will try to fight against his own master. A name is safe if and only if no character appears in both the first name and the last name.

Since no two clones can share a name, Darth Vader would like to know the maximum number of clones he is able to create.
 

Input
The First line of the input contains an integer  T  ( T10 ), denoting the number of test cases. 

Each test case contains two integers  n  and  m  ( 1n,m2000 ).
 

Output
For each test case, output one line containing the maximum number of clones Vader can create.

Output the answer   mod 109+7
 

Sample Input
  
  
2 3 2 2 3
 

Sample Output
  
  
2 18

枚举要为这两段分配的颜色数目分别为  i,j  ,则在第一段总共有  (mi)  种选取方案,在第二段总共有  (mij)  种选取方案。

而在每段内部,我们设  F(n,x)  为长度为  n  的格子使用  x  种颜色(等于  x  )染色的方案数。

则根据容斥原理  F(n,x)=xn(x1)(x1)n+(x2)(x2)n(x3)(x3)n+...

于是最终的结果便是所有  (mi)F(n,i)×(mij)F(n,j)  之和。

代码:
#include <bits/stdc++.h>

using namespace std;

typedef long long LL;
const int N=2011;
const int mod=1e9+7;
LL C[N][N];
LL J[N][N];
LL res[N];
void Init()
{
    C[0][0]=1;
    for(int i=1; i<=2000; i++)
    {
        C[i][0]=1;
        J[i][0]=1;
        for(int j=1; j<=2000; j++)
        {
            if(j<=i)
                C[i][j]=(C[i-1][j]+C[i-1][j-1])%mod;
            J[i][j]=J[i][j-1]*i%mod;
        }
    }
    return ;
}
int main()
{
    int t;
    Init();
    scanf("%d",&t);
    while(t--)
    {
        int n,m;
        scanf("%d%d",&n,&m);
        memset(res,0,sizeof(res));
        for(int i=1; i<m; i++)
        {
            LL cnt=0;
            for(int k=0; k<=i; k++)
            {
                if(k&1)cnt=(cnt-C[i][k]*J[i-k][n]%mod+mod)%mod;
                else cnt=(cnt+C[i][k]*J[i-k][n]%mod)%mod;
            }
            res[i]=cnt;
        }
        LL ans=0;
        for(int i=1; i<m; i++)
            for(int j=i; j+i<=m; j++)
            {
                LL a=C[m][i]*res[i]%mod;
                LL b=C[m-i][j]*res[j]%mod;
                LL cnt=(a*b)%mod;
                if(i!=j)
                    cnt=cnt*2%mod;
                ans=(ans+cnt)%mod;
            }
        printf("%lld\n",ans);
    }
    return 0;
}
#include <cstdio>
#include <algorithm>
using namespace std;
const int N=2011;
const int mod=1e9+7;
typedef long long LL;
LL a[N][N];
LL C[N][N];
void Init()
{
    C[0][0]=1;
    for(int i=1; i<=2000; i++)
    {
        a[i][0]=1;
        for(int j=1; j<=i; j++)
        {
            C[i][j]=(C[i-1][j]*j+C[i-1][j-1])%mod;
            a[i][j]=(a[i][j-1]*(i-j+1))%mod;
        }
    }
}
int main()
{
    Init();
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n,m;
        scanf("%d%d",&n,&m);
        LL ans=0;
        for(int i=1;i<m;i++)
            for(int j=1;j+i<=m;j++)
        {
            ans=(ans+C[n][i]*C[n][j]%mod*a[m][i+j]%mod)%mod;
        }
        printf("%lld\n",ans);
    }
    return 0;
}


 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值