构造矩阵+矩阵快速幂

HDU 5950(Recursive sequence)

转载:https://i-blog.csdnimg.cn/blog_migrate/eeaea593baba0776fdc572b6cfdd68e0.png

Recursive sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 29    Accepted Submission(s): 19


Problem Description
Farmer John likes to play mathematics games with his N cows. Recently, they are attracted by recursive sequences. In each turn, the cows would stand in a line, while John writes two positive numbers a and b on a blackboard. And then, the cows would say their identity number one by one. The first cow says the first number a and the second says the second number b. After that, the i-th cow says the sum of twice the (i-2)-th number, the (i-1)-th number, and  i4 . Now, you need to write a program to calculate the number of the N-th cow in order to check if John’s cows can make it right. 
 

Input
The first line of input contains an integer t, the number of test cases. t test cases follow.
Each case contains only one line with three numbers N, a and b where N,a,b <  231  as described above.
 

Output
For each test case, output the number of the N-th cow. This number might be very large, so you need to output it modulo 2147493647.
 

Sample Input
   
   
2 3 1 2 4 1 10
 

Sample Output
   
   
85 369
Hint
In the first case, the third number is 85 = 2*1十2十3^4. In the second case, the third number is 93 = 2*1十1*10十3^4 and the fourth number is 369 = 2 * 10 十 93 十 4^4.
 

题意:

已知递推公式:F(n) = 2*F(n-2) + F(n-1) + nF(1) = aF(2) = b;给定一个N,求F(N)等于多少?

由于N很大,直接递推肯定超时,所以要用到矩阵快速幂的知识log(n)的复杂度来解决。问题的关键就在于如何构造矩阵上,可以看出本题的递推公式是一个非线性的式子,所以要将非线性的部分展开为线性的。





代码:
#include <cstdio>
#include <cstdlib>
#include <algorithm>
#include <cmath>
#include <iostream>
#include <cstring>

using namespace std;

typedef long long int ll;
const ll mod = 2147493647;

//定义矩阵乘法 
struct matrix{
    ll arr[7][7];
    matrix operator*(matrix b){
        matrix ans;
        ll tmp;
        for(int i=0; i<7; i++)
            for(int j=0; j<7; j++){
                ans.arr[i][j] = 0;
                for(int k=0; k<7; k++){
                    tmp = (arr[i][k]*b.arr[k][j])%mod;
                    ans.arr[i][j] = (ans.arr[i][j] + tmp)%mod;
                }        
            }
        return ans;
    }
};

//矩阵快速幂 
matrix quick_pow(matrix a,ll N){
    matrix ans;
    memset(ans.arr,0,sizeof(ans.arr));
    for(int i=0; i<7; i++)
        ans.arr[i][i] = 1;
    while(N){
        if(N&1)
            ans = ans*a;
        a = a*a;
        N /= 2;; 
    }
    return ans;
}

int main(){
    
    matrix a;
    memset(a.arr,0,sizeof(a.arr));
    a.arr[0][1] = 1;
    a.arr[1][1] = a.arr[1][2] = a.arr[1][6] = 1;
    a.arr[2][2] = a.arr[2][6] = 1;
    a.arr[1][0] = 2; a.arr[1][3] = a.arr[1][5] = a.arr[2][3] = a.arr[2][5] = 4;
    a.arr[1][4] = a.arr[2][4] = 6;
    a.arr[3][3] = a.arr[4][4] = a.arr[5][5] = a.arr[6][6] = 1;
    a.arr[3][6] = a.arr[4][6] = a.arr[5][6] = 1;
    a.arr[3][4] = a.arr[3][5] = 3;
    a.arr[4][5] = 2;
    int T;
    scanf("%d",&T);
    ll N,aa,bb;
    while(T--){
        scanf("%I64d %I64d %I64d",&N,&aa,&bb);
        if(N==1)
            printf("%I64d\n",aa);
        else if(N==2)
            printf("%I64d\n",bb);
        else{
            matrix ans = quick_pow(a,N-2);
            ll ANS = 0;
            ANS = (ANS+ans.arr[1][0]*aa)%mod;
            ANS = (ANS+ans.arr[1][1]*bb)%mod;
            ANS = (ANS+ans.arr[1][2]*16)%mod;
            ANS = (ANS+ans.arr[1][3]*8)%mod;
            ANS = (ANS+ans.arr[1][4]*4)%mod;
            ANS = (ANS+ans.arr[1][5]*2)%mod;
            ANS = (ANS+ans.arr[1][6]*1)%mod;
            printf("%I64d\n",ANS);
        }
    } 
    return 0;
}
  • 0
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值