1146 Topological Order (25 分)(拓扑图)

This is a problem given in the Graduate Entrance Exam in 2018: Which of the following is NOT a topological order obtained from the given directed graph? Now you are supposed to write a program to test each of the options.

gre.jpg

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (≤ 1,000), the number of vertices in the graph, and M (≤ 10,000), the number of directed edges. Then M lines follow, each gives the start and the end vertices of an edge. The vertices are numbered from 1 to N. After the graph, there is another positive integer K (≤ 100). Then K lines of query follow, each gives a permutation of all the vertices. All the numbers in a line are separated by a space.

Output Specification:

Print in a line all the indices of queries which correspond to "NOT a topological order". The indices start from zero. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line. It is graranteed that there is at least one answer.

Sample Input:

6 8
1 2
1 3
5 2
5 4
2 3
2 6
3 4
6 4
5
1 5 2 3 6 4
5 1 2 6 3 4
5 1 2 3 6 4
5 2 1 6 3 4
1 2 3 4 5 6

Sample Output:

3 4

题意:一共n个点,m条边,给出m条边的start和end。有k种方案,若该方案不构成拓扑图则输出,输出样例之间有空格,结尾后无多余空格。

思路:

  • vector<int> v[1005] 二维向量,作为邻接表
  • in[1005]记录点的入度
  • flag在每次询问前置0,若该方案无法形成拓扑结构置为1,后续输出
  • place标记是否该输出空格(曾经输出过数据则置为1,后不再输出空格)

k次询问,每次n个点,每读进一个点(预备删除),先看他的入度是否为零否则flag=1;遍历该点的邻接表,对应元素入度依次减1.符合要求continue,否则输出……

#include<bits/stdc++.h>
using namespace std;
vector<int> v[1005];
int in[1005];
int main() {
	int n,m,a,b,k,place=0;
	scanf("%d %d",&n,&m);
	for(int i=0; i<m; i++) {
		scanf("%d %d",&a,&b);
		v[a].push_back(b);
		in[b]++;
	}
	scanf("%d",&k);
	for(int i=0;i<k;i++){
		int flag=0;
		vector<int> tin(in,in+n+1);
		for(int j=0;j<n;j++){
			scanf("%d",&a);
			if(tin[a]!=0) flag=1;
			for(int p=0;p<v[a].size();p++)
				tin[v[a][p]]--;
		}
		if(flag==0) continue;
		printf("%s%d",place==1?" ":"",i); 
		place=1;
	}
	return 0;
}	

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值