1142 Maximal Clique (25 分)(部分完全图/最大部分完全图)

A clique is a subset of vertices of an undirected graph such that every two distinct vertices in the clique are adjacent. A maximal clique is a clique that cannot be extended by including one more adjacent vertex. (Quoted from https://en.wikipedia.org/wiki/Clique_(graph_theory))

Now it is your job to judge if a given subset of vertices can form a maximal clique.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers Nv (≤ 200), the number of vertices in the graph, and Ne, the number of undirected edges. Then Ne lines follow, each gives a pair of vertices of an edge. The vertices are numbered from 1 to Nv.

After the graph, there is another positive integer M (≤ 100). Then M lines of query follow, each first gives a positive number K (≤ Nv), then followed by a sequence of K distinct vertices. All the numbers in a line are separated by a space.

Output Specification:

For each of the M queries, print in a line Yes if the given subset of vertices can form a maximal clique; or if it is a clique but not a maximal clique, print Not Maximal; or if it is not a clique at all, print Not a Clique.

Sample Input:

8 10
5 6
7 8
6 4
3 6
4 5
2 3
8 2
2 7
5 3
3 4
6
4 5 4 3 6
3 2 8 7
2 2 3
1 1
3 4 3 6
3 3 2 1

Sample Output:

Yes
Yes
Yes
Yes
Not Maximal
Not a Clique

题意:给出有nv个点ne条边的无向图,共k次询问,问这些点构成的集合是否是完全图 / 最大完全图

思路:

  • mp[a][b]=1,代表a和b之间有边,将每次询问的点集合放入v[205](下标为0到k-1),and flag[i]标记为1
  • 两层for循环判断是否每两个点都有边——否则不是完全图
  • 对任意一个不是询问点集中的点,依次判断是否与点集中所有点都有边,只要有一个不存在即可break,判断下一个
  • 若当前判断到最后一个点则置标记不是最大完全图
  • 否则是最大完全图
#include<bits/stdc++.h>
using namespace std;
int mp[205][205];
int nv;
void Check() {
	int k,isMaximal=1;//初值!!! 
	vector<int> v(205);
	int flag[205]= {0};
	scanf("%d",&k);
	for(int i=0; i<k; i++) {
		scanf("%d",&v[i]);
		flag[v[i]]=1; //i v[i]
	}
	for(int i=0; i<k; i++) {
		for(int j=0; j<i; j++) {
			if(mp[v[i]][v[j]]==0) {
				printf("Not a Clique\n");
				return;
			}
		}
	}

	for(int i=1; i<=nv; i++) {
		if(flag[i]==0) {
			for(int j=0; j<k; j++) {
				if(mp[i][v[j]]==0) break; //只要有一个边不相连即不必判断 
				if(j==k-1) isMaximal=0;  //到达最后一条边说明与不是最大的clique 
			}
		}
		if(isMaximal==0){
			printf("Not Maximal\n");
			return;
		}
	}
	printf("Yes\n");
}
int main() {
	int ne,m,a,b;
	scanf("%d %d",&nv,&ne);
	for(int i=1; i<=ne; i++) {
		scanf("%d %d",&a,&b);
		mp[a][b]=mp[b][a]=1;
	}
	scanf("%d",&m);
	while(m--) {
		Check();
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
以下是非递归实现任意柱状图求最大矩形面积的C语言代码: ```c #include <stdio.h> #include <stdlib.h> #include <limits.h> // 定义栈结构体 typedef struct { int top; // 栈顶指针 int* arr; // 存储栈元素的数组 } Stack; // 创建一个栈 Stack* create(int size) { Stack* s = (Stack*)malloc(sizeof(Stack)); s->top = -1; s->arr = (int*)malloc(sizeof(int) * size); return s; } // 判断栈是否为空 int isEmpty(Stack* s) { return s->top == -1; } // 判断栈是否已满 int isFull(Stack* s, int size) { return s->top == size - 1; } // 入栈 void push(Stack* s, int x) { s->arr[++s->top] = x; } // 出栈 int pop(Stack* s) { return s->arr[s->top--]; } // 获取栈顶元素 int peek(Stack* s) { return s->arr[s->top]; } // 求最大矩形面积 int largestRectangleArea(int* heights, int heightsSize) { Stack* s = create(heightsSize + 1); // 创建栈,栈的大小为 heightsSize + 1 int maxArea = 0; // 最大矩形面积 int i = 0; // 遍历 heights 数组的指针 while (i < heightsSize || !isEmpty(s)) { if (isEmpty(s) || heights[i] >= heights[peek(s)]) { push(s, i++); // 如果栈为空或当前元素大于等于栈顶元素,将当前元素入栈 } else { int top = pop(s); // 如果当前元素小于栈顶元素,弹出栈顶元素 int width = isEmpty(s) ? i : i - peek(s) - 1; // 计算矩形宽度 int area = heights[top] * width; // 计算矩形面积 if (area > maxArea) { maxArea = area; // 更新最大矩形面积 } } } // 释放栈占用的内存 free(s->arr); free(s); return maxArea; } // 求矩阵中最大矩形面积 int maximalRectangle(char** matrix, int matrixSize, int* matrixColSize) { if (matrixSize == 0 || matrixColSize == NULL || matrixColSize[0] == 0) { return 0; } int n = matrixColSize[0]; // 矩阵的列数 int* heights = (int*)malloc(sizeof(int) * n); // 存储每一行的高度 int maxArea = 0; // 最大矩形面积 for (int i = 0; i < matrixSize; i++) { // 计算当前行的高度 for (int j = 0; j < n; j++) { if (matrix[i][j] == '0') { heights[j] = 0; } else { heights[j]++; } } // 计算以当前行为底边的最大矩形面积 int area = largestRectangleArea(heights, n); if (area > maxArea) { maxArea = area; // 更新最大矩形面积 } } // 释放 heights 数组占用的内存 free(heights); return maxArea; } int main() { char* matrix[] = {"10100", "10111", "11111", "10010"}; int matrixSize = sizeof(matrix) / sizeof(char*); int matrixColSize[] = {5, 5, 5, 5}; int maxArea = maximalRectangle(matrix, matrixSize, matrixColSize); printf("最大矩形面积:%d\n", maxArea); return 0; } ``` 该算法的时间复杂度为O(mn),空间复杂度为O(n),其中m为矩阵的行数,n为矩阵的列数。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值