1110 Complete Binary Tree (25 分)(完全二叉树)

Given a tree, you are supposed to tell if it is a complete binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤20) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each case, print in one line YES and the index of the last node if the tree is a complete binary tree, or NO and the index of the root if not. There must be exactly one space separating the word and the number.

Sample Input 1:

9
7 8
- -
- -
- -
0 1
2 3
4 5
- -
- -

Sample Output 1:

YES 8

Sample Input 2:

8
- -
4 5
0 6
- -
2 3
- 7
- -
- -

Sample Output 2:

NO 1

题意:n个点,给出每个孩子的左右节点,“-”表示结点为空,判断是否为二叉完全树 。若是输出最后一个结点的序号,否则输出根节点序号

思路:

  • 处理输入,不为空结点have标记置为1
  • 找出根节点dfs
  • dfs(root,id); root代表当前结点的下标,id(根节点为1)表示若为二叉完全树当前结点的坐标(1-n),每次若id>maxn则更新maxn和 最大节点的序号(root与ans比较)
  • 最后判断maxn==n? 若是则为二叉完全树,否则……
#include<bits/stdc++.h>
using namespace std;
struct node{
	int l,r;
}p[105];
int have[105];
int maxn=-1,ans;
void dfs(int root,int id){
	if(id>maxn){
		maxn=id;
		ans=root;
	}
	if(p[root].l!=-1) dfs(p[root].l,2*id);
	if(p[root].r!=-1) dfs(p[root].r,2*id+1);
}
int main(){
	int n,root=0;
	string a,b;
	cin>>n;
	for(int i=0;i<n;i++){
		cin>>a>>b;
		if(a=="-") p[i].l=-1;
		else{
			p[i].l=stoi(a);
			have[p[i].l]=1;
		}
		if(b=="-") p[i].r=-1;
		else{
			p[i].r=stoi(b);
			have[p[i].r]=1;
		}
	}
	while(have[root]) root++;
	dfs(root,1);
	if(maxn==n) cout<<"YES "<<ans;
	else cout<<"NO "<<root;
	return 0;
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值