1110 Complete Binary Tree (25分) 完全二叉树 遍历

Given a tree, you are supposed to tell if it is a complete binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤20) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each case, print in one line YES and the index of the last node if the tree is a complete binary tree, or NO and the index of the root if not. There must be exactly one space separating the word and the number.

Sample Input 1:

9
7 8
- -
- -
- -
0 1
2 3
4 5
- -
- -

Sample Output 1:

YES 8

Sample Input 2:

8
- -
4 5
0 6
- -
2 3
- 7
- -
- -

Sample Output 2:

NO 1
#include <iostream>
#include <vector>
#include <string>

using namespace std;

struct node
{
	int l, r;
}v[100];
int maxn = -1, ans;
void dfs(int root, int index)
{
	if (index > maxn)
	{
		maxn = index;
		ans = root;
	}
	if (v[root].l != -1)
	{
		dfs(v[root].l, index * 2 );
	}
	if (v[root].r != -1)
	{
		dfs(v[root].r, index * 2 + 1);
	}
}

int main()
{
	//freopen("in.txt", "r", stdin);
	int n, root = 0, have[100] = { 0 };
	cin >> n;
	for (int i = 0; i < n; i++)
	{
		string l, r;
		cin >> l >> r;
		if (l=="-")
		{
			v[i].l = -1;
		}
		else
		{
			v[i].l = stoi(l);
			have[stoi(l)] = 1;
		}
		if (r=="-")
		{
			v[i].r = -1;
		}
		else
		{
			v[i].r = stoi(r);
			have[stoi(r)] = 1;
		}
	}
	while (have[root]==1)
	{
		root++;
	}
	dfs(root, 1);
	if (n==maxn)
	{
		cout << "YES " << ans;
	}
	else
	{
		cout << "NO " << root << endl;
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值