1127 ZigZagging on a Tree (30 分) (Z字形层序输出二叉树)

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences. And it is a simple standard routine to print the numbers in level-order. However, if you think the problem is too simple, then you are too naive. This time you are supposed to print the numbers in "zigzagging order" -- that is, starting from the root, print the numbers level-by-level, alternating between left to right and right to left. For example, for the following tree you must output: 1 11 5 8 17 12 20 15.

zigzag.jpg

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the inorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the zigzagging sequence of the tree in a line. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

8
12 11 20 17 1 15 8 5
12 20 17 11 15 8 5 1

Sample Output:

1 11 5 8 17 12 20 15

题意: 给出中序和后序,Z字形层序输出二叉树。

思路:

  1. int post[35], in[35];
  2. int tree[35][2],tree【i】【0】表示左子树,1表示右子树。
  3. vector<int> ans[30]: 从第一层到最深的一层,保存每一层的点在post【】中的位置。

dfs(int &id, int inl, int inr, int postl, int postr )

  • 递归出口是inl>inr
  • 找根结点在in【】中的位置
  • 递归找左右子树

bfs()

  1. queue<node> q;
  2. 第一个结点,node{root,0}
  3. 队列不空的时候,取出第一个节点,push进该层的ans,若左右节点不为空,push进队列。
#include<bits/stdc++.h>
using namespace std;
int in[35],post[35],tree[35][2],root;
vector<int> ans[30];
struct node {
	int id,depth;
};
void dfs(int &id,int inl,int inr,int postl,int postr) {
	if(inl>inr) return;
	id=postr;
	int k=0;
	while(in[k]!=post[postr]) k++;
	dfs(tree[id][0],inl,k-1,postl,postl+(k-inl)-1);
	dfs(tree[id][1],k+1,inr,postl+(k-inl),postr-1);
}
void bfs() {
	node tmp;
	queue<node> q;
	q.push(node {root,0});
	while(!q.empty()) {
		tmp=q.front();
		q.pop();
		ans[tmp.depth].push_back(post[tmp.id]);
		if(tree[tmp.id][0]!=0) q.push(node {tree[tmp.id][0],tmp.depth+1});
		if(tree[tmp.id][1]!=0) q.push(node {tree[tmp.id][1],tmp.depth+1});
	}
}
int main() {
	int n;
	scanf("%d",&n);
	for(int i=1; i<=n; i++) scanf("%d",&in[i]);
	for(int i=1; i<=n; i++) scanf("%d",&post[i]);
	dfs(root,1,n,1,n);
	bfs();
	cout<<ans[0][0];
	for(int i=1; i<30; i++) {
		if(i%2==1) {
			for(int j=0; j<ans[i].size(); j++)
				printf(" %d",ans[i][j]);
		} else {
			for(int j=ans[i].size()-1; j>=0; j--)
				printf(" %d",ans[i][j]);
		}
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值