1127. ZigZagging on a Tree

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences. And it is a simple standard routine to print the numbers in level-order. However, if you think the problem is too simple, then you are too naive. This time you are supposed to print the numbers in "zigzagging order" -- that is, starting from the root, print the numbers level-by-level, alternating between left to right and right to left. For example, for the following tree you must output: 1 11 5 8 17 12 20 15.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<= 30), the total number of nodes in the binary tree. The second line gives the inorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the zigzagging sequence of the tree in a line. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
8
12 11 20 17 1 15 8 5
12 20 17 11 15 8 5 1
Sample Output:
1 11 5 8 17 12 20 15

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
#include<vector>
using namespace std;
const int maxn=40;
int in[maxn],post[maxn];
struct node{
	int v;
	node *lchild,*rchild;
};
void create(node* &root,int inL,int inR,int postL,int postR)
{
	if(inL>inR)return;
	if(root==NULL)
	{
		root=new node;
		root->v=post[postR];
		root->lchild=root->rchild=NULL;
	}
	int leftnum=0,k=inL;
	for(;k<=inR;k++)
	{
		if(in[k]==post[postR])break;
		leftnum++;
	}
	create(root->lchild,inL,k-1,postL,postL+leftnum-1);
	create(root->rchild,k+1,inR,postL+leftnum,postR-1);
}
void zigzagging(node* root,int n)
{
	queue<node*> q;
	vector<node*> v;
	int level=0,num=0;
	q.push(root);
	while(!q.empty())
	{
		while(!q.empty())
		{
			node* top=q.front();
			q.pop();
			v.push_back(top);
		}
		if(level%2==0)
		{
			for(int i=v.size()-1;i>=0;i--)
			{
				printf("%d",v[i]->v);
				num++;
				if(num<n)printf(" ");
				else printf("\n");
			}
		}else
		{
			for(int i=0;i<v.size();i++)
			{
				printf("%d",v[i]->v);
				num++;
				if(num<n)printf(" ");
				else printf("\n");
			}
		}
		level++;
		for(int i=0;i<v.size();i++)
		{
			if(v[i]->lchild!=NULL)q.push(v[i]->lchild);
			if(v[i]->rchild!=NULL)q.push(v[i]->rchild);
		}
		v.clear();
	}
}
int main()
{
	int n;
	scanf("%d",&n);
	for(int i=0;i<n;i++)
		scanf("%d",&in[i]);
	for(int i=0;i<n;i++)
		scanf("%d",&post[i]);
	node* root=NULL;
	create(root,0,n-1,0,n-1);
	zigzagging(root,n);
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值