1051 Pop Sequence (25 分) (模拟栈)

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO

cur从1到n,则全部出栈,若在进栈过程中 栈满NO,符合顺序则出栈 

#include<bits/stdc++.h>
using namespace std;
int main() {
	int m,n,k;
	scanf("%d%d%d",&m,&n,&k);
	vector<int> v(n+1);
	while(k--) {
		for(int i=1; i<=n; i++)
			scanf("%d",&v[i]);
		stack<int> st;//如不在此建站,则需事后清空 
		int cur=1,flag=0;
		for(int i=1; i<=n; i++) {//从1到 n依次入栈 
			st.push(i);
			if(st.size()>m) break;//超出栈的大小 
			while(!st.empty()&&st.top()==v[cur]){ //若相等说明此刻退栈(非空) 
				st.pop();
				cur++;
			}
		}
		if(cur==n+1) flag=1;
		if(flag) cout<<"YES\n";
		else cout<<"NO\n"; 
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值