【ZCMU1041】二哥的困惑 Ⅳ(大整数)

题目链接

 

1041: 二哥的困惑 Ⅳ

Time Limit: 1 Sec  Memory Limit: 128 MB
Submit: 275  Solved: 89
[Submit][Status][Web Board]

Description

 

 

A Fibonacci sequence is calculated by adding the previous two members of the sequence, with the first two members being both 1.

f(1) = 1, f(2) = 1, f(n > 2) = f(n - 1) + f(n - 2)

Your task is to take a number as input, and print that Fibonacci number.

 

Input


Input contains several cases, every case contains a positive integer number N.

Output

print the Nth Fibonacci number.

Sample Input

100

Sample Output

354224848179261915075

HINT

 

Source

 

解题思路:

布吉岛有没有别的方法,反正我是用Java大整数类做的。

 

代码:

import java.math.BigInteger;
import java.util.Scanner;
public class Main {
	public static void main(String args[]) {
		Scanner in=new Scanner(System.in);
		int n;
		BigInteger a[]=new BigInteger[1005];
		while(in.hasNext()) {
			n=in.nextInt();
			a[1]=BigInteger.valueOf(1);
			a[2]=BigInteger.valueOf(1);
			for(int i=3;i<=n;i++)
				a[i]=a[i-1].add(a[i-2]);
			System.out.println(a[n]);
		}
	}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值