【ZOJ2750】Idiomatic Phrases Game(最短路)

题目链接

Idiomatic Phrases Game


Time Limit: 2 Seconds      Memory Limit: 65536 KB


Tom is playing a game called Idiomatic Phrases Game. An idiom consists of several Chinese characters and has a certain meaning. This game will give Tom two idioms. He should build a list of idioms and the list starts and ends with the two given idioms. For every two adjacent idioms, the last Chinese character of the former idiom should be the same as the first character of the latter one. For each time, Tom has a dictionary that he must pick idioms from and each idiom in the dictionary has a value indicates how long Tom will take to find the next proper idiom in the final list. Now you are asked to write a program to compute the shortest time Tom will take by giving you the idiom dictionary.

Input

The input consists of several test cases. Each test case contains an idiom dictionary. The dictionary is started by an integer N (0 < N < 1000) in one line. The following is N lines. Each line contains an integer T (the time Tom will take to work out) and an idiom. One idiom consists of several Chinese characters (at least 3) and one Chinese character consists of four hex digit (i.e., 0 to 9 and A to F). Note that the first and last idioms in the dictionary are the source and target idioms in the game. The input ends up with a case that N = 0. Do not process this case.

Output

One line for each case. Output an integer indicating the shortest time Tome will take. If the list can not be built, please output -1.

Sample Input

5
5 12345978ABCD2341
5 23415608ACBD3412
7 34125678AEFD4123
15 23415673ACC34123
4 41235673FBCD2156
2
20 12345678ABCD
30 DCBF5432167D
0

Sample Output

17
-1


【题意】

成语接龙,每个成语由4个16进制数组成,看是否能从第一个成语接到最后一个成语,接每个成语需要翻字典有耗时,如果能接到最后一个成语,则输出最少耗时,反之输出-1。

 

【解题思路】

将首尾能对应成语建边,权值为时间,然后用dijkstra跑一遍最短路。如果dis[n-1]=INF,说明没有能接到最后一个成语,所以输出-1,否则输出最短路。

 

【代码】

#include<bits/stdc++.h>
using namespace std;
const int INF=999999999;
const int maxn=1005;
int edge[maxn][maxn],vis[maxn],dis[maxn];
char s[maxn];
int n;
struct Node
{
    char a[5],b[5];
    int time;
}node[maxn];
void dijkstra()
{
    for(int i=0;i<n;i++)
        dis[i]=INF;
    dis[0]=0;
    while(1)
    {
        int v=-1;
        for(int i=0;i<n;i++)
        {
            if(!vis[i] && (v==-1 |dis[i]<dis[v]))
                v=i;
        }
        if(v==-1)break;
        vis[v]=1;
        for(int i=0;i<n;i++)
            dis[i]=min(dis[i],dis[v]+edge[v][i]);
    }
}
int main()
{
    while(~scanf("%d",&n) && n)
    {
        for(int i=0;i<n;i++)
        {
            scanf("%d %s",&node[i].time,s);
            int l=strlen(s);
            for(int k=0,j=l-1;k<4;j--,k++)
            {
                node[i].a[k]=s[k];
                node[i].b[3-k]=s[j];
            }
            node[i].a[4]=node[i].b[4]='\0';
        }
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<n;j++)
            {
                edge[i][j]=INF;
                if(i==j)continue;
                if(strcmp(node[i].b,node[j].a)==0)
                    edge[i][j]=node[i].time;
            }
        }
        memset(vis,0,sizeof(vis));
        dijkstra();
        if(dis[n-1]==INF)printf("-1\n");
        else printf("%d\n",dis[n-1]);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip 【备注】 1、该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的,请放心下载使用!有问题请及时沟通交流。 2、适用人群:计算机相关专业(如计科、信息安全、数据科学与大数据技术、人工智能、通信、物联网、自动化、电子信息等)在校学生、专业老师或者企业员工下载使用。 3、用途:项目具有较高的学习借鉴价值,不仅适用于小白学习入门进阶。也可作为毕设项目、课程设计、大作业、初期项目立项演示等。 4、如果基础还行,或热爱钻研,亦可在此项目代码基础上进行修改添加,实现其他不同功能。 欢迎下载!欢迎交流学习!不清楚的可以私信问我! 毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值