【ZCMU3037】Block Towers(贪心)

题目链接

3037: Block Towers

Time Limit: 2 Sec  Memory Limit: 256 MB
Submit: 48  Solved: 20
[Submit][Status][Web Board]

Description

C. Block Towers

Students in a class are making towers of blocks. Each student makes a (non-zero) tower by stacking pieces lengthwise on top of each other. n of the students use pieces made of two blocks and m of the students use pieces made of three blocks.

The students don’t want to use too many blocks, but they also want to be unique, so no two students’ towers may contain the same number of blocks. Find the minimum height necessary for the tallest of the students' towers.

Input

 The first line of the input contains two space-separated integers n and m (0≤n,m≤1000000, n+m>0)− the number of students using two-block pieces and the number of students using three-block pieces, respectively.

Output

 Print a single integer, denoting the minimum possible height of the tallest tower.

Sample Input

1 3

Sample Output

9

HINT

 

 In the first case, the student using two-block pieces can make a tower of height 4, and the students using three-block pieces can make towers of height 3, 6, and 9 blocks. The tallest tower has a height of 9 blocks.

 

【题意】

有n个人用2层的砖块建塔,有m个人用3层的砖块建塔,每个人的塔的高度要求不同,求最少的砖块能构造的最高的塔的高度。

 

【解题思路】

被最高的塔的最小高度困扰了好久……

因为每个人建塔的高度要求不同,可以先考虑如果可以相同的话,可以建的最高的塔的最小高度肯定是max(2*n,3*m)。

比如n=4,m=3时n个人可建的塔为2 4 6 8  m个人可建的塔为3 6 9,但最小高度不是9,因为高度为6的塔重复了(事实上之后所有6的倍数的塔高都会重复,只需比较n和m的最小值是否大于6的倍数,如果大,肯定会存在重复),所以只需比较8和9的大小,因为8比9小,为了满足题意,就将8+2=10,最后再求个max(n,m)即可。

 

【代码】

#include<bits/stdc++.h>
using namespace std;
int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m))
    {
        n*=2;
        m*=3;
        int x=6;
        while(x<=min(n,m))
        {
            if(n<m)n+=2;
            else m+=3;
            x+=6;
        }
        printf("%d\n",max(n,m));
    }
    return 0;
}
 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值