PAT A 1028 List Sorting (25分)

1028 List Sorting (25分)

吐槽

极速编程二连。基础的sort函数应用。
不过如果不是C用不了sort函数可能写排序代码得要一会儿?
(所以C++好啊!)

逻辑

就是实现三个cmp函数嘛。

坑点

再用int表达定位数ID我就把自己手剁下来。

题目

Excel can sort records according to any column. Now you are supposed to imitate this function.

Input Specification:
Each input file contains one test case. For each case, the first line contains two integers N (≤10
​5
​​ ) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record of a student. A student’s record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

Output Specification:
For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID’s; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID’s in increasing order.

Sample Input 1:
3 1
000007 James 85
000010 Amy 90
000001 Zoe 60
Sample Output 1:
000001 Zoe 60
000007 James 85
000010 Amy 90
Sample Input 2:
4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98
Sample Output 2:
000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60
Sample Input 3:
4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 90
Sample Output 3:
000001 Zoe 60
000007 James 85
000002 James 90
000010 Amy 90

代码

#include<iostream>
#include<algorithm>
#include<string>

using namespace std;

typedef struct Student
{
	string ID;
	string name;
	int grade;
}student;

student* s;

bool cmp1(student s1, student s2)
{
	return s1.ID < s2.ID;
}

bool cmp2(student s1, student s2)
{
	if (s1.name < s2.name)
		return true;
	else if (s1.name == s2.name&&s1.ID < s2.ID)
		return true;
	else
		return false;
}

bool cmp3(student s1, student s2)
{
	if (s1.grade < s2.grade)
		return true;
	else if (s1.grade == s2.grade&&s1.ID < s2.ID)
		return true;
	else
		return false;
}

int main()
{
	int n,k;
	cin >> n >> k;
	s = new student[n];
	for (int i = 0; i < n; i++)
	{
		cin >> s[i].ID >> s[i].name >> s[i].grade;
	}
	
	if (k == 1)
		sort(s, s + n, cmp1);
	else if (k == 2)
		sort(s, s + n, cmp2);
	else if (k == 3)
		sort(s, s + n, cmp3);
	for (int i = 0; i < n; i++)
	{
		cout << s[i].ID << " " << s[i].name << " " << s[i].grade << endl;
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值