POJ 1369 Genealogical tree|拓扑排序

问题描述

http://algorithm.openjudge.cn/2020hw1/2B/

总时间限制: 1000ms 内存限制: 65536kB

描述

The system of Martians' blood relations is confusing enough. Actually, Martians bud when they want and where they want. They gather together in different groups, so that a Martian can have one parent as well as ten. Nobody will be surprised by a hundred of children. Martians have got used to this and their style of life seems to them natural.
And in the Planetary Council the confusing genealogical system leads to some embarrassment. There meet the worthiest of Martians, and therefore in order to offend nobody in all of the discussions it is used first to give the floor to the old Martians, than to the younger ones and only than to the most young childless assessors. However, the maintenance of this order really is not a trivial task. Not always Martian knows all of his parents (and there's nothing to tell about his grandparents!). But if by a mistake first speak a grandson and only than his young appearing great-grandfather, this is a real scandal.
Your task is to write a program, which would define once and for all, an order that would guarantee that every member of the Council takes the floor earlier than each of his descendants.

输入

The first line of the standard input contains an only number N, 1 <= N <= 100 — a number of members of the Martian Planetary Council. According to the centuries-old tradition members of the Council are enumerated with the natural numbers from 1 up to N. Further, there are exactly N lines, moreover, the I-th line contains a list of I-th member's children. The list of children is a sequence of serial numbers of children in a arbitrary order separated by spaces. The list of children may be empty. The list (even if it is empty) ends with 0.

输出

The standard output should contain in its only line a sequence of speakers' numbers, separated by spaces. If several sequences satisfy the conditions of the problem, you are to write to the standard output any of them. At least one such sequence always exists.

样例输入

5
0
4 5 1 0
1 0
5 3 0
3 0

样例输出

2 4 5 3 1

 

问题解决

拓扑排序的思路就是每轮都找到一个入度为0的节点,把这个点删掉,并将它连的所有的边也删掉,具体的更新体现在每个节点入度的减少。

其中que用的不太好感觉,看到有用数组的,不仅在迭代过程中充当队列,还记录了所有的轨迹,最后再统一输出用时应该能更少些。

#include <iostream>
#include <vector>
using namespace std;

int cnt[105];
int vis[105];
vector<int> children[105];

int main(){
    int N;
    cin>>N;
    for(int i=1;i<=N;i++){
        int tmp;
        while(cin>>tmp && tmp!=0){
            children[i].push_back(tmp);
            cnt[tmp]++;
        }
    }

    int rest=N;
    bool start = true;
    while(rest>0){
        vector<int> que;
        for(int i=1;i<=N;i++){
            if(!cnt[i] && !vis[i]){
                que.push_back(i);
            }
        }
        for(int i=0;i<que.size();i++){
            vis[que[i]]=1;
            if (start==true) {cout<<que[i];start = false;}
            else {cout<<' '<<que[i];}
                
            for(int j=0;j<children[que[i]].size();j++){
                cnt[children[que[i]][j]]--;
            }
            rest--;
        }
    }
    cout<<endl;
    return 0;
}

本来以为每轮都必须要找所有的入度为0的节点,后来发现只要找到一个即可,不用重新开一个数组,直接输出就行了:

#include <iostream>
#include <vector>
using namespace std;

int cnt[105];
int vis[105];
vector<int> children[105];

int main(){
    int N;
    cin>>N;
    for(int i=1;i<=N;i++){
        int tmp;
        while(cin>>tmp && tmp!=0){
            children[i].push_back(tmp);
            cnt[tmp]++;
        }
    }

    int rest=N;
    bool start = true;
    while(rest>0){
        int s;
        for(int i=1;i<=N;i++){
            if(!cnt[i] && !vis[i]){
                s=i;
                break;
            }
        }
        vis[s]=1;
        if (start==true) {cout<<s;start = false;}
        else {cout<<' '<<s;}
            
        for(int j=0;j<children[s].size();j++){
            cnt[children[s][j]]--;
        }
        rest--;
        
    }
    cout<<endl;
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值