拓扑排序模板 POJ-2367 Genealogical tree

The system of Martians' blood relations is confusing enough. Actually, Martians bud when they want and where they want. They gather together in different groups, so that a Martian can have one parent as well as ten. Nobody will be surprised by a hundred of children. Martians have got used to this and their style of life seems to them natural.

And in the Planetary Council the confusing genealogical system leads to some embarrassment. There meet the worthiest of Martians, and therefore in order to offend nobody in all of the discussions it is used first to give the floor to the old Martians, than to the younger ones and only than to the most young childless assessors. However, the maintenance of this order really is not a trivial task. Not always Martian knows all of his parents (and there's nothing to tell about his grandparents!). But if by a mistake first speak a grandson and only than his young appearing great-grandfather, this is a real scandal.
Your task is to write a program, which would define once and for all, an order that would guarantee that every member of the Council takes the floor earlier than each of his descendants.
Input
The first line of the standard input contains an only number N, 1 <= N <= 100 — a number of members of the Martian Planetary Council. According to the centuries-old tradition members of the Council are enumerated with the natural numbers from 1 up to N. Further, there are exactly N lines, moreover, the I-th line contains a list of I-th member's children. The list of children is a sequence of serial numbers of children in a arbitrary order separated by spaces. The list of children may be empty. The list (even if it is empty) ends with 0.
Output
The standard output should contain in its only line a sequence of speakers' numbers, separated by spaces. If several sequences satisfy the conditions of the problem, you are to write to the standard output any of them. At least one such sequence always exists.
Sample Input
5
0
4 5 1 0
1 0
5 3 0
3 0
Sample Output
2 4 5 3 1题意
给出n行,从1到n表示第1,2,3....n个人,接下来n行表示第i个人的后代序号,每行以0结束,求这些人的年长顺序。
题解
典型的拓扑排序,可惜在比赛时没想到,先找入度最小的,然后减去和它有关系的边,这样一直找,最后就可以得出这些人的排序。
#include<stdio.h>           //拓扑排序
#include<string.h>
#include<algorithm>
using namespace std;
int main()
{
    int i,n,in[105],mapp[105][105],print[105],m,w,s=0,k;
    while(~scanf("%d",&n))
    {
        int i,j,book[105];
        memset(mapp,0,sizeof(mapp));
        memset(in,0,sizeof(in));
        memset(book,0,sizeof(book));
        for(i=1; i<=n; i++) 
        {
            scanf("%d",&m);
            if(m==0)
                continue;
            while(m!=0)
            {
                if(mapp[i][m]==0)        //m是i的后代
                {
                    mapp[i][m]=1;        //防止重复
                    in[m]++;             //入度
                }
                scanf("%d",&m);
            }
        }
        for(i=1; i<=n; i++)
        {
            for(j=1; j<=n; j++)
            {
                if(book[j]==0&&in[j]==0)  //找没有入度的,即祖先
                {
                    book[j]=1;
                    w=j;
                    break;
                }
            }
            print[s++]=w;               //存到数组里
            for(k=1; k<=n; k++)
            {
                if(mapp[w][k]==1)      //和w有关系的边
                {
                    mapp[w][k]=0;      //这个边标记为0,减掉这条边
                    in[k]--;          //出度
                }
            }
        }
        for(i=0; i<s; i++)
        {
            if(i!=s-1)
                printf("%d ",print[i]);
            else
                printf("%d\n",print[i]);
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值