PAT 1114 Family Property (并查集)

1114 Family Property (25分)

This time, you are supposed to help us collect the data for family-owned property. Given each person's family members, and the estate(房产)info under his/her own name, we need to know the size of each family, and the average area and number of sets of their real estate.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤1000). Then N lines follow, each gives the infomation of a person who owns estate in the format:

ID Father Mother k Child​1​​⋯Child​k​​ M​estate​​ Area

where ID is a unique 4-digit identification number for each person; Father and Mother are the ID's of this person's parents (if a parent has passed away, -1 will be given instead); k (0≤k≤5) is the number of children of this person; Child​i​​'s are the ID's of his/her children; M​estate​​ is the total number of sets of the real estate under his/her name; and Area is the total area of his/her estate.

Output Specification:

For each case, first print in a line the number of families (all the people that are related directly or indirectly are considered in the same family). Then output the family info in the format:

ID M AVG​sets​​ AVG​area​​

where ID is the smallest ID in the family; M is the total number of family membersAVG​sets​​ is the average number of sets of their real estate; and AVG​area​​ is the average area. The average numbers must be accurate up to 3 decimal places. The families must be given in descending order of their average areas, and in ascending order of the ID's if there is a tie.

Sample Input:

10
6666 5551 5552 1 7777 1 100
1234 5678 9012 1 0002 2 300
8888 -1 -1 0 1 1000
2468 0001 0004 1 2222 1 500
7777 6666 -1 0 2 300
3721 -1 -1 1 2333 2 150
9012 -1 -1 3 1236 1235 1234 1 100
1235 5678 9012 0 1 50
2222 1236 2468 2 6661 6662 1 300
2333 -1 3721 3 6661 6662 6663 1 100

Sample Output:

3
8888 1 1.000 1000.000
0001 15 0.600 100.000
5551 4 0.750 100.000

 题目大意:给出每个成员的id和其父母的id,以及这位成员的孩子数,房子套数,房子面积。让你统计出家庭人口,人均房产套数,人均房产面积。输出信息格式是:家庭成员最小编号 家庭人口数 人均房产套数 人均房产面积, 其中人均的需要保留三位小数。家庭信息按人均房产面积降序输出,如果一样,则按id升序输出

如何解决:使用并查集(好久没写了……),将一个家庭的编号都合并在一起,选id最小的为父节点,计算套数,面积,根据父id一样来统计家庭人数;标记父id,有多少个父id就说明有多少个家庭。

(真的有印象之前写过这道题,可能是打天梯的时候写过……忘完了撒……)

/*
好久没写并查集了…… 
输出: 
家庭成员最小的id,家庭成员人数,人均房产套数 ,人均房产面积 
*/
 
#include <bits/stdc++.h>
#define Max 10010
using namespace std;
struct people{
	int id, father, mother;
	int setNum;
	double area;
	people(){
		father = mother = -1;
		area = setNum = 0;
	}
}peo[Max]; 
struct family{
	int id;
	int peoNum; //家庭总人数
	int setNum;//房子套数
	double areaNum; //总面积 
	double setAvg, areaAvg; //人均房套,人均房面 
	int flag;
}fam[Max];
int fa[Max], n, k, vis[Max];
void init(){
	memset(vis, 0, sizeof(vis));
	for(int i = 0; i < Max; i++){
		fa[i] = i;
		fam[i].flag = 0;
	}
}
bool cmp(family a, family b){
	if(a.areaAvg != b.areaAvg){
		return a.areaAvg > b.areaAvg;
	}
	return a.id < b.id;
}
int Find(int x){
	while(x != fa[x])
		x = fa[x];
	return x;
}
void mix(int a,int b){
	int Fa = Find(a);
	int Fb = Find(b);
	if(Fa > Fb){
		fa[Fa] = Fb;
	}else fa[Fb] = Fa;
}
int main(){
	
	int cnt = 0;
	init();
	scanf("%d", &n);
	for(int i = 0; i < n; i++){
		scanf("%d %d %d %d",&peo[i].id, &peo[i].father, &peo[i].mother, &k);
		vis[peo[i].id] = 1;
		if(peo[i].father != -1) {
			vis[peo[i].father] = 1;
			mix(peo[i].id, peo[i].father);
		}
		if(peo[i].mother != -1){
			vis[peo[i].mother] = 1;
			mix(peo[i].id, peo[i].mother);
		}
		int childId;
		for(int j = 0; j < k; j++){
			scanf("%d", &childId);
			vis[childId]= 1;
			mix(peo[i].id, childId);
		}
		scanf("%d %lf",&peo[i].setNum, &peo[i].area);
	}
	for(int i = 0; i < n; i++){
		int rt = Find(peo[i].id);
		fam[rt].id = rt;
		fam[rt].setNum += peo[i].setNum;
		fam[rt].areaNum += peo[i].area;
		fam[rt].flag = true;
	}
	//找family size 
	for(int i = 0; i < Max; i++){
		if(vis[i]){
			fam[Find(i)].peoNum++;
		}
		if(fam[i].flag){
			cnt++;
		} 
	}
	for(int i = 0; i < Max; i++){
		if(fam[i].flag){
			fam[i].areaAvg = fam[i].areaNum*1.0 / fam[i].peoNum;
			fam[i].setAvg = fam[i].setNum*1.0 / fam[i].peoNum;
		}
	}
	sort(fam, fam+Max, cmp);
	printf("%d\n", cnt);
	for(int i = 0; i < cnt; i++){
		printf("%04d %d %.3lf %.3lf\n", fam[i].id, fam[i].peoNum, fam[i].setAvg, fam[i].areaAvg);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值