1107 Social Clusters (30分)
When register on a social network, you are always asked to specify your hobbies in order to find some potential friends with the same hobbies. A social cluster is a set of people who have some of their hobbies in common. You are supposed to find all the clusters.
Input Specification:
Each input file contains one test case. For each test case, the first line contains a positive integer N (≤1000), the total number of people in a social network. Hence the people are numbered from 1 to N. Then N lines follow, each gives the hobby list of a person in the format:
Ki: hi[1] hi[2] ... hi[Ki]
where Ki (>0) is the number of hobbies, and hi[j] is the index of the j-th hobby, which is an integer in [1, 1000].
Output Specification:
For each case, print in one line the total number of clusters in the network. Then in the second line, print the numbers of people in the clusters in non-increasing order. The numbers must be separated by exactly one space, and there must be no extra space at the end of the line.
Sample Input:
8
3: 2 7 10
1: 4
2: 5 3
1: 4
1: 3
1: 4
4: 6 8 1 5
1: 4
Sample Output:
3
4 3 1
有相同爱好(一个即可)的人是一个圈子,判断有多少个圈子,并且输出每个圈子的人数
并查集~~~
#include <bits/stdc++.h>
#define Max 1005
using namespace std;
int pre[Max], hobby[Max], num[Max];
int n, k, h;
void init(){
memset(hobby, -1, sizeof(hobby));
memset(num, 0, sizeof(num));
for(int i = 0; i <= n; i++)
pre[i] = i;
}
int find(int x){
if(pre[x] == x) return x;
else return pre[x] = find(pre[x]);
}
int mix(int a, int b){
int fa = find(a);
int fb = find(b);
if(fa!=fb) pre[fa] = fb;
}
int cmp(int a, int b){
return a > b;
}
int main(){
cin >> n;
init();
for(int i = 1; i <= n; i++){
cin >> k;
scanf(":");
for(int j = 0; j < k; j++){
cin >> h;
if(hobby[h] == -1) hobby[h] = i;
else mix(hobby[h], i);
}
}
int cnt = 0;
for(int i = 1; i <= n; i++){
int fa = find(i);
if(fa == i){
cnt ++;
}
num[fa] ++;
}
sort(num+1, num+1+n, cmp);
cout << cnt << endl;
for(int i = 1; i <= n; i++){
if(num[i] == 0) break;
if(i == 1) cout << num[i];
else cout << " " << num[i];
}
cout << endl;
return 0;
}