PAT 1067 Sort with Swap(0, i) (贪心) 

14 篇文章 0 订阅

1067 Sort with Swap(0, i) (25分)

Given any permutation of the numbers {0, 1, 2,..., N−1}, it is easy to sort them in increasing order. But what if Swap(0, *) is the ONLY operation that is allowed to use? For example, to sort {4, 0, 2, 1, 3} we may apply the swap operations in the following way:

Swap(0, 1) => {4, 1, 2, 0, 3}
Swap(0, 3) => {4, 1, 2, 3, 0}
Swap(0, 4) => {0, 1, 2, 3, 4}

Now you are asked to find the minimum number of swaps need to sort the given permutation of the first N nonnegative integers.

Input Specification:

Each input file contains one test case, which gives a positive N (≤10​5​​) followed by a permutation sequence of {0, 1, ..., N−1}. All the numbers in a line are separated by a space.

Output Specification:

For each case, simply print in a line the minimum number of swaps need to sort the given permutation.

Sample Input:

10
3 5 7 2 6 4 9 0 8 1

Sample Output:

9

题意:给你n个数的序列(0~n-1),交换排序的时候只能跟0交换,当序列有序的时候求最少的交换次数

方法:贪心:已经在合适位置上的元素就不需要动了,我们需要记录除了0不在合适位置上的元素(代码中的cnt);

看0所在的位置,如果0不在位置0,那么0在哪个位置就和那个元素交换;如果0在位置0,因为我们需要借助0使其他的元素归位,所以就找第一个不在适合位置上的元素与0交换

#include <bits/stdc++.h>
#define Max 110005
using namespace std;
int n, a[Max];
int pos[Max];
int cnt, ans; 
int main(){
	memset(a, 0, sizeof(a));
	memset(pos, 0, sizeof(pos));
	ans = 0;
	cin >> n;
	cnt = n - 1;
	for(int i = 0; i < n; i++){
		cin >> a[i];
		pos[a[i]] = i;
		if(a[i] == i && a[i] != 0) cnt--;//需要交换的 
	}
	int j = 1;
	while(cnt){
		if(pos[0] != 0){
			swap(pos[0], pos[pos[0]]);
			cnt--;
			ans++;
		}else{
			for(;j < n; j++){  //前边的顺序都安排好了 每次从 j 开始遍历 如果 每次 从头遍历 会超时 
				if(pos[j] != j){
					swap(pos[0], pos[j]);
					ans++;
					break;
				}
			}
		}
	} 
	cout << ans << endl;
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值