PAT 1151 LCA in a Binary Tree (建树+lca)

1151 LCA in a Binary Tree (30分)

The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.

Given any two nodes in a binary tree, you are supposed to find their LCA.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 1,000), the number of pairs of nodes to be tested; and N (≤ 10,000), the number of keys in the binary tree, respectively. In each of the following two lines, N distinct integers are given as the inorder and preorder traversal sequences of the binary tree, respectively. It is guaranteed that the binary tree can be uniquely determined by the input sequences. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.

Output Specification:

For each given pair of U and V, print in a line LCA of U and V is A. if the LCA is found and A is the key. But if A is one of U and V, print X is an ancestor of Y. where X is A and Y is the other node. If U or V is not found in the binary tree, print in a line ERROR: U is not found. or ERROR: V is not found. or ERROR: U and V are not found..

Sample Input:

6 8
7 2 3 4 6 5 1 8
5 3 7 2 6 4 8 1
2 6
8 1
7 9
12 -3
0 8
99 99

Sample Output:

LCA of 2 and 6 is 3.
8 is an ancestor of 1.
ERROR: 9 is not found.
ERROR: 12 and -3 are not found.
ERROR: 0 is not found.
ERROR: 99 and 99 are not found.

 看到这个题的第一反应就是 根据中序 先序 把树构造出来,然后再搜祖先

(柳神有更好的想法,不需要建树)

//中序 先序构造树 再求公共祖先 
#include <bits/stdc++.h>
#define Max 11111
using namespace std;
int n, m;
int in[Max], pre[Max]; 
struct node{
	int val;
	node *left, *right;
	node(int v): val(v), left(NULL), right(NULL){} 
} *root;
node* build(int rt, int st, int end){
	if(st > end) return NULL;
	int i = st;
	while(i < end && in[i] != pre[rt]) i++;
	node *n = new node(in[i]);
	n -> left = build(rt+1, st, i-1);
	n -> right = build(rt+1+(i - st), i+1, end);
	return n;
}
//看节点存不存在 
bool find(node *rt, int val){
	if(!rt) return false;
	if(rt->val == val) return true;
	return find(rt->left, val) || find(rt->right, val);
}
node* lca(node *rt, int a, int b){
	if(!rt) return NULL;
	if(rt->val == a || rt->val == b) return rt;
	node *l = lca(rt->left, a, b);
	node *r = lca(rt->right, a, b);
	if(l & r) return rt;
	return l == NULL ? r: l;
} 
int main() {
	int a, b;
	cin >> m >> n;
	for(int i = 0; i < n; i++) 
		cin >> in[i];
	for(int j = 0; j < n; j++)
		cin >> pre[j];
	root = build(0, 0, n-1);
	while(m--) {
		cin >> a >> b;
		bool fing_a = find(root, a);
        bool find_b = find(root, b);
        if(find_a && find_b) {
            node *n = lca(root, a, b);
            if(n->val != a && n->val != b) printf("LCA of %d and %d is %d.\n", a, b, n->val);
            else if(n->val == a) printf("%d is an ancestor of %d.\n", a, b);
            else printf("%d is an ancestor of %d.\n", b, a);
        } else {
            if(!find_a && !find_b) printf("ERROR: %d and %d are not found.\n", a, b);
            else if(!find_a) printf("ERROR: %d is not found.\n", a);
            else printf("ERROR: %d is not found.\n", b);
        }
	}	
	
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值