POJ 2407 Relatives (欧拉函数 模板题)

Given n, a positive integer, how many positive integers less than n are relatively prime to n? Two integers a and b are relatively prime if there are no integers x > 1, y > 0, z > 0 such that a = xy and b = xz.

Input

There are several test cases. For each test case, standard input contains a line with n <= 1,000,000,000. A line containing 0 follows the last case.

Output

For each test case there should be single line of output answering the question posed above.

Sample Input

7
12
0

Sample Output

6
4

欧拉函数->https://blog.csdn.net/qq_40046426/article/details/81454091

/*欧拉函数 计算 1-N中 与 N 互质的个数*/

MY BLOG

#include <iostream>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <queue>
using namespace std;
#define ll long long
/*
ll power(ll a,ll b,ll mod)
{
    int ans=1,base=a;
    while(b)
    {
        if(b&1) ans=ans*base%mod;
        base=base*base%mod;
        b>>=1;
    }
    return ans;
}*/
int euler(ll n)
{
    ll res=n;
    for(int i=2;i*i<=n;i++)
    {
        if(n%i==0)
        {
            res=res/i*(i-1);//res=res*(1-1/p)->res=res*(p-1)/p;-->res=res/p*(p-1) (先除防止中间数据溢出)||或者 res-=res/i;
            while(n%i==0)
                n/=i;
        }
    }
    if(n>1) res=res/n*(n-1);//或者 res-=res/a;
    return res;
}
int main()
{
    ll n;
    while(cin>>n)
    {
        if(n==0)break;
        cout<<euler(n)<<endl;
    }return 0;
}

/*
Euler函数表达通式:euler(x)=x(1-1/p1)(1-1/p2)(1-1/p3)(1-1/p4)…(1-1/pn),其中p1,p2……pn为x的所有素因数,x是不为0的整数。euler(1)=1(唯一和1互质的数就是1本身)。
*/

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值