HDU 1052 Tian Ji -- The Horse Racing (贪心)

Tian Ji -- The Horse Racing

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 38958    Accepted Submission(s): 11672

Problem Description

Here is a famous story in Chinese history.

"That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others."

"Both of Tian and the king have three horses in different classes, namely, regular, plus, and super. The rule is to have three rounds in a match; each of the horses must be used in one round. The winner of a single round takes two hundred silver dollars from the loser."

"Being the most powerful man in the country, the king has so nice horses that in each class his horse is better than Tian's. As a result, each time the king takes six hundred silver dollars from Tian."

"Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver dollars and such a grace in the next match."

"It was a rather simple trick. Using his regular class horse race against the super class from the king, they will certainly lose that round. But then his plus beat the king's regular, and his super beat the king's plus. What a simple trick. And how do you think of Tian Ji, the high ranked official in China?"



Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in the ACM contest right now, he may discover that the horse racing problem can be simply viewed as finding the maximum matching in a bipartite graph. Draw Tian's horses on one side, and the king's horses on the other. Whenever one of Tian's horses can beat one from the king, we draw an edge between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds as possible is just to find the maximum matching in this graph. If there are ties, the problem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and find a maximum weighted perfect matching...

However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses --- a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a too advanced tool to deal with the problem.

In this problem, you are asked to write a program to solve this special case of matching problem.

Input

The input consists of up to 50 test cases. Each case starts with a positive integer n (n <= 1000) on the first line, which is the number of horses on each side. The next n integers on the second line are the speeds of Tian’s horses. Then the next n integers on the third line are the speeds of the king’s horses. The input ends with a line that has a single 0 after the last test case.

Output

For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.

 

Sample Input

3

92 83 71

95 87 74

2

20 20

20 20

2

20 19

22 18

0

Sample Output

200

0

0

在家竟然无聊到想学习,,,我还是刷题吧 哎……

田忌赛马,,,刚开始看题没看明白 以为 是 匈牙利……没想到是贪心(瞎搞)hhhhh

题意:田忌与齐王赛马,赢了得200 输了输200。。二分图的最大匹配,求田忌最后的得到的最大money

……(田忌竟然敢赢齐王,真是闲自己活得时间很长啊……还有田忌最快的马可能比齐王的还快,这齐王的面子怎能挂得住,命不久矣……)

/*
从最快的马开始
如果 田忌 最快的马比 齐王最快的马快 则 赢一盘
如果 田忌 最快的马比 齐王最快的马慢 则 用田忌最慢的马来消耗 齐王最快的马 输一盘
如果 田忌 最快的马比 齐王最快的马相等 则 
	先用田忌最慢的马与齐王最慢的马比,如果比齐王快,则赢一盘
	如果比齐王慢,则去与齐王最快的马相比 消耗齐王最快的马 输一盘
	如果一样的话,消耗田忌最慢的马与齐王最快的马 
*/
#include <iostream>
#include <cstring>
#include <string>
#include <stack>
#include <queue>
#include <vector>
#include <cstdio>
#include <map>
#include <iomanip> 
#include <cmath>
#include <algorithm>
#define pi acos(-1.0)
#define ll long long
#define inf 0x3f3f3f3f
#define Max 1001
using namespace std;
int main()
{
	int n,a[Max],b[Max];
	while(cin>>n,n)
	{
		memset(a,0,sizeof(a));
		memset(b,0,sizeof(b));
		for(int i=0;i<n;i++)
		{//田忌 
			cin>>a[i];
		}
		for(int i=0;i<n;i++)
		{//齐王 
			cin>>b[i];
		}
		int amax,amin,bmax,bmin,ans=0;
		sort(a,a+n);
		sort(b,b+n);
		amax=bmax=n-1;
		amin=bmin=0;
		for(int i=0;i<n;i++)//比n轮 
		{
			if(a[amax]>b[bmax])
			{
				ans+=200;
				amax--;
				bmax--;
			}else if(a[amax]<b[bmax])
			{
				ans-=200;
				bmax--;
				amin++;				
			}else if(a[amax]==b[bmax])
			{
				if(a[amin]>b[bmin])
				{
					ans+=200;
					amin++;
					bmin++;
				}else if(a[amin]<=b[bmin])//田忌最慢的马比齐王最慢的马慢/相等 
				{
					if(a[amin]<b[bmax])//田忌最慢的马可能与齐王最快的马 速度相等 ,所以这里需要注意一下 
					{
						ans-=200;
						amin++;
						bmax--;
					}else if(a[amin]==b[bmax])
					{
						amin++;
						bmax--;
					}
				}
			}
		}cout<<ans<<endl;
	}
	return 0;
}

 

评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值