POJ 2528 Mayor's posters(线段树区间覆盖+离散化)

Mayor's posters

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 87859 Accepted: 25207

Description

The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral posters at all places at their whim. The city council has finally decided to build an electoral wall for placing the posters and introduce the following rules: 

  • Every candidate can place exactly one poster on the wall. 
  • All posters are of the same height equal to the height of the wall; the width of a poster can be any integer number of bytes (byte is the unit of length in Bytetown). 
  • The wall is divided into segments and the width of each segment is one byte. 
  • Each poster must completely cover a contiguous number of wall segments.


They have built a wall 10000000 bytes long (such that there is enough place for all candidates). When the electoral campaign was restarted, the candidates were placing their posters on the wall and their posters differed widely in width. Moreover, the candidates started placing their posters on wall segments already occupied by other posters. Everyone in Bytetown was curious whose posters will be visible (entirely or in part) on the last day before elections. 
Your task is to find the number of visible posters when all the posters are placed given the information about posters' size, their place and order of placement on the electoral wall. 

Input

The first line of input contains a number c giving the number of cases that follow. The first line of data for a single case contains number 1 <= n <= 10000. The subsequent n lines describe the posters in the order in which they were placed. The i-th line among the n lines contains two integer numbers li and ri which are the number of the wall segment occupied by the left end and the right end of the i-th poster, respectively. We know that for each 1 <= i <= n, 1 <= li <= ri <= 10000000. After the i-th poster is placed, it entirely covers all wall segments numbered li, li+1 ,... , ri.

Output

For each input data set print the number of visible posters after all the posters are placed. 

The picture below illustrates the case of the sample input. 

Sample Input

1
5
1 4
2 6
8 10
3 4
7 10

Sample Output

4

线段树区间覆盖+离散化。

题意:候选人在墙上贴海报,海报的高度相同,宽度不同,先贴的可能会被后贴的盖上,问最后有多少个可见的海报,只要不是全部遮挡完,都算。

方法:

线段树维护一个区间,tree[i].w代表当前维护的区间情况, -1代表没有海报,或者不止一个海报,为v时代表当前区间被第几个海报覆盖。

query:如果w=k,说明有这个编号的海报,vis标记避免重复,然后返回1,如果是叶子节点,则停止,如果不是叶子节点,就继续递归

离散化:

10000000太大,减不了数组,但是10000个海报,最多有20000个点,所以建一个1-10000000到1-20000的映射,这就是离散化了。

在我理解看来就是将一个很大的区间映射为一个很小的区间,而不改变原有的大小覆盖关系,但是注意简单的离散化可能

会出现错误,给出下面两个简单的例子应该能体现普通离散化的缺陷:
例子一:1-10 1-4 5-10
例子二:1-10 1-4 6-10
普通离散化后都变成了[1,4][1,2][3,4]
线段2覆盖了[1,2],线段3覆盖了[3,4],那么线段1是否被完全覆盖掉了呢?
例子一是完全被覆盖掉了,而例子二没有被覆盖

解决的办法则是对于距离大于1的两相邻点,中间再插入一个点,

来自:blog

关于Max*3的问题是因为海报本来两个边是Max*2但是如果两个数之间都加上一个数 那就是 Max*3,然后线段树要开4倍空间所以是12

代码:

#include <iostream>
#include <cstring>
#include <string>
#include <algorithm>
#include <stack>
#include <cmath>
#include <cstdio>
#define Max 11000
using namespace std;
struct Node {
    int l, r, w;
}tree[Max*12];
int vis[Max*3], init[Max][2], a[Max*3], cnt ,n;
void pushdown(int k) {
    tree[k << 1].w = tree[k << 1 | 1].w = tree[k].w;
    tree[k].w = -1;
}
void build(int k, int l, int r) {
    tree[k].l = l; tree[k].r = r; tree[k].w = -1;
    if(l == r) {
        tree[k].w = -1;
        return ;
    }
    int mid = (l + r) >> 1;
    build(k << 1, l, mid);
    build(k << 1 | 1, mid+1, r);
}
//区间更新
void update(int k, int l, int r, int v) {
    if(l > tree[k].r || r < tree[k].l) return ;
    if(l <= tree[k].l && tree[k].r <= r) {
        tree[k].w = v;
        return ;
    }
    if(tree[k].w != -1) pushdown(k);
    update(k << 1, l, r, v);
    update(k << 1 | 1, l, r, v);
}
int query(int k){
    if(tree[k].w != -1) {
        if(!vis[tree[k].w]) {
            vis[tree[k].w] = 1;
            return 1;
        }
        return 0;
    }
    if(tree[k].l == tree[k].r) {
        return 0;
    }
    return query(k << 1) + query(k << 1 | 1);
}
int main() {
    ios::sync_with_stdio(false);
    int t;
    cin >> t;
    while (t--) {
        cnt = 0;
        memset(vis, 0, sizeof(vis));
        memset(init, 0, sizeof(init));
        cin >> n;
        for (int i = 0; i < n; i++) {
            cin >> init[i][0] >> init[i][1];
            a[cnt++] = init[i][0];
            a[cnt++] = init[i][1];
        }
        sort(a, a + cnt);
        // cout << "cnt: " << cnt << endl;
        int tot = unique(a, a + cnt) - a;//去重后的点的个数
        //unique的作用是“去掉”容器中相邻元素的重复元素
        // cout << "tot:" << tot << endl;
        for (int i = tot - 1; i >= 1; i--){
            // cout << a[i] << endl;
            if (a[i] - a[i-1] > 1) {
                a[tot++] = a[i] - 1;
            //要把相差超过1的数据的特点体现出来,使得其之间有空隙。方法就是在这两个数中间再加一个数
            }
        }
        build(1, 1, tot);
        sort(a, a + tot);
        
        for(int i = 0; i < n; i++) {
            int x = lower_bound(a, a + tot, init[i][0]) - a + 1;//树定义的下标从1开始
            int y = lower_bound(a, a + tot, init[i][1]) - a + 1;
            update(1, x, y, i + 1);//i+1 表示从1到N,第几个区间
        }
        cout << query(1) << endl;
    }
    return 0;
}
/*

1
5
1 4
2 6
8 10
3 4
7 10
*/

C++ AC,G++ RE

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值