POJ - 2528 Mayor's posters(线段树区间覆盖+离散化)

The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral posters at all places at their whim. The city council has finally decided to build an electoral wall for placing the posters and introduce the following rules: 

  • Every candidate can place exactly one poster on the wall. 
  • All posters are of the same height equal to the height of the wall; the width of a poster can be any integer number of bytes (byte is the unit of length in Bytetown). 
  • The wall is divided into segments and the width of each segment is one byte. 
  • Each poster must completely cover a contiguous number of wall segments.


They have built a wall 10000000 bytes long (such that there is enough place for all candidates). When the electoral campaign was restarted, the candidates were placing their posters on the wall and their posters differed widely in width. Moreover, the candidates started placing their posters on wall segments already occupied by other posters. Everyone in Bytetown was curious whose posters will be visible (entirely or in part) on the last day before elections. 
Your task is to find the number of visible posters when all the posters are placed given the information about posters' size, their place and order of placement on the electoral wall. 

Input

The first line of input contains a number c giving the number of cases that follow. The first line of data for a single case contains number 1 <= n <= 10000. The subsequent n lines describe the posters in the order in which they were placed. The i-th line among the n lines contains two integer numbers l i and ri which are the number of the wall segment occupied by the left end and the right end of the i-th poster, respectively. We know that for each 1 <= i <= n, 1 <= l i <= ri <= 10000000. After the i-th poster is placed, it entirely covers all wall segments numbered l i, l i+1 ,... , ri.

Output

For each input data set print the number of visible posters after all the posters are placed. 

The picture below illustrates the case of the sample input. 

Sample Input

1
5
1 4
2 6
8 10
3 4
7 10

Sample Output

4

题意:

给出一面单位长度最大为10000000的墙,在墙上依次贴海报,给出每张海报贴的位置(高度都一样高,可理解为线段线段覆盖),求最后能够看到几张海报(露出一部分也算能够看到)。

 

解题思路:
本想直接套用区间改值的模板,发现这道题只要将每个区间更新为当前覆盖的海报的编号即可,输入所有的海报更新完线段树以后扫描一下当前有多少不为0的结点即是能看到多少张海报。

因为读入数据比较大,再给线段树开n*4的空间显然会超内存,所以需要采用离散化的思想,所谓离散化就是在不改变原来数据关系的基础上,将原来的数据映射到较小的一段数据上。

 

AC代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<vector>
using namespace std;
#define MAXX 20010

struct node
{
    int l,r,w;
}tree[MAXX*10];

struct N
{
	int x,y;
}s[MAXX];

int book[MAXX],a[MAXX];


void build(int v,int l,int r)
{
    tree[v].l=l;
	tree[v].r=r;
    if(tree[v].l==tree[v].r)
    {
        tree[v].w=0; 
        return;
    }
    int mid=(l+r)/2;
    build(v*2,l,mid);
    build(v*2+1,mid+1,r);
}

void downupdate(int v) 
{
    tree[v*2].w=tree[v*2+1].w=tree[v].w;
	tree[v].w=0;
}

void ask_interval(int v,int a,int b)
{
	if(tree[v].l==tree[v].r&&tree[v].w==0) return;//为0表示当前区间没有被覆盖 
	if(tree[v].l>=a&&tree[v].r<=b&&tree[v].w!=0)//当前区间被覆盖 
    {
        book[tree[v].w]=1;//记下这张海报的下标 
        return;
    }
    int mid=(tree[v].l+tree[v].r)/2;
    if(a<=mid) ask_interval(v*2,a,b);
    if(b>mid) ask_interval(v*2+1,a,b);
}

void changeupdate_interval(int v,int a,int b,int y)//区间改值,[a,b]内所有数同时修改为y 
{
    if(tree[v].l>=a&&tree[v].r<=b)
    {
        tree[v].w=y;
        return;
    }
    if(tree[v].w!=0) downupdate(v); 
    
    int mid=(tree[v].l+tree[v].r)/2;
    if(a<=mid) changeupdate_interval(v*2,a,b,y);
    if(b>mid) changeupdate_interval(v*2+1,a,b,y);
}

int main()
{
	int t,n;
	scanf("%d",&t);
	while(t--)
	{
		vector<int> v;//使用vector方便去重  
		memset(tree,0,sizeof(tree));
		memset(book,0,sizeof(book));
		
		scanf("%d",&n);
		for(int i=1;i<=n;i++)
		{
			scanf("%d%d",&s[i].x,&s[i].y);
			v.push_back(s[i].x);
			v.push_back(s[i].y);
		}
		sort(v.begin(),v.end()); 
		v.erase(unique(v.begin(),v.end()),v.end());//去除数列中重复的数,unique函数将数列中重复的数都移到了最后 
		
		//离散化,将原本相邻的数保持相邻,不相邻的数间隔为2,不改变原来的关系 
		int cnt=1;
		a[0]=1;
		for(int i=1;i<v.size();i++)
		{
			if(v[i]==v[i-1]+1)
			{
				cnt++;
				a[i]=cnt;
			}
			else
			{
				cnt+=2;
				a[i]=cnt;
			}
		}
		
		build(1,1,v.size()*2+10);//建树,所有结点值初始为0 
		
//		for(int i=1;i<=v.size()*2+10;i++)
//		{
//			printf("%d ",tree[i].w);
//		}
//		printf("\n");
		
		int x,y;
		for(int i=1;i<=n;i++)//找到每个数字在离散化后对应的数字 
		{
			x=a[(lower_bound(v.begin(),v.end(),s[i].x)-v.begin())];
			y=a[(lower_bound(v.begin(),v.end(),s[i].y)-v.begin())];
			changeupdate_interval(1,x,y,i);//覆盖[x,y]区间,区间值更新为当前海报的下标 
		}
		
//		for(int i=1;i<=v.size()*2+10;i++)
//		{
//			printf("%d ",tree[i].w);
//		}
//		printf("\n");
		
		ask_interval(1,1,v.size()*2+10);//查询当前区间覆盖了多少张海报 
		
		//printf("**********\n");
		int sum=0;
		for(int i=1;i<=n;i++)
		{
			if(book[i]) sum++;//如果当前海报的下标被book记录下来了则能看到 
		}
		printf("%d\n",sum);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值