PAT (Advanced Level) Practice 1077 Kuchiguse

                                      1077 Kuchiguse

The Japanese language is notorious for its sentence ending particles. Personal preference of such particles can be considered as a reflection of the speaker's personality. Such a preference is called "Kuchiguse" and is often exaggerated artistically in Anime and Manga. For example, the artificial sentence ending particle "nyan~" is often used as a stereotype for characters with a cat-like personality:

  • Itai nyan~ (It hurts, nyan~)

  • Ninjin wa iyada nyan~ (I hate carrots, nyan~)

Now given a few lines spoken by the same character, can you find her Kuchiguse?

Input Specification:

Each input file contains one test case. For each case, the first line is an integer N (2≤N≤100). Following are N file lines of 0~256 (inclusive) characters in length, each representing a character's spoken line. The spoken lines are case sensitive.

Output Specification:

For each test case, print in one line the kuchiguse of the character, i.e., the longest common suffix of all N lines. If there is no such suffix, write nai.

Sample Input 1:

3
Itai nyan~
Ninjin wa iyadanyan~
uhhh nyan~

Sample Output 1:

nyan~

Sample Input 2:

3
Itai!
Ninjinnwaiyada T_T
T_T

Sample Output 2:

nai

running code:

#include<stdio.h>
#include<string.h>
#include<stdbool.h>
int n,minlen=256,res=0;
char s[100][256];
int main()
{
  scanf("%d",&n);
  getchar();
  for(int i=0;i<n;i++)
  {
    gets(s[i]);
    int len=strlen(s[i]);
    if(len<minlen) minlen=len;
    for(int j=0;j<len/2;j++)
    {
       char temp=s[i][j];
       s[i][j]=s[i][len-j-1];
       s[i][len-1-j]=temp;
    }
  }
  for(int i=0;i<minlen;i++)
  {
    char c=s[0][i];
    bool same=true;
    for(int j=1;j<n;j++)
    {
      if(c!=s[j][i]){
        same=false;
        break;
      }
    }
    if(same) res++;
    else break;
  }
  if(res) {
   for(int i=res-1;i>=0;i--)
   {
     printf("%c",s[0][i]);
   }
  }
  else
  {
    printf("nai");
  }
  return 0;
}

 

result:

notice:

1.读入n之后要使用getchar接收换行符,否则for循环内的gets读入的这个换行符会导致第一个字符串读取错误。

2.由于字符串有空格符,因此不能用scanf来读取字符串,因为scanf的%s格式是以空格为结束标志的,这样会导致字符串读入不完整。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值