1077 Kuchiguse (20 分)

1077 Kuchiguse (20 分)

The Japanese language is notorious for its sentence ending particles. Personal preference of such particles can be considered as a reflection of the speaker’s personality. Such a preference is called “Kuchiguse” and is often exaggerated artistically in Anime and Manga. For example, the artificial sentence ending particle “nyan~” is often used as a stereotype for characters with a cat-like personality:

Itai nyan~ (It hurts, nyan~)

Ninjin wa iyada nyan~ (I hate carrots, nyan~)

Now given a few lines spoken by the same character, can you find her Kuchiguse?

Input Specification:
Each input file contains one test case. For each case, the first line is an integer N (2≤N≤100). Following are N file lines of 0~256 (inclusive) characters in length, each representing a character’s spoken line. The spoken lines are case sensitive.

Output Specification:
For each test case, print in one line the kuchiguse of the character, i.e., the longest common suffix of all N lines. If there is no such suffix, write nai.

Sample Input 1:
3
Itai nyan~
Ninjin wa iyadanyan~
uhhh nyan~
Sample Output 1:
nyan~
Sample Input 2:
3
Itai!
Ninjinnwaiyada T_T
T_T
Sample Output 2:
nai

#include<stdio.h>
#include<string.h>
char a[10000][100000];
int n;
void traverse(char s[]) {
  int temp;
  int len = strlen(s);
  for(int i = 0; i < len/2; i++){
    temp = s[i];
    s[i] = s[len - i -1];
    s[len - i - 1] = temp;
  }
}

int min(int n) {
  int min = 1000;
  int temp;
  for(int i = 0; i < n; i++) {
    temp = strlen(a[i]);
    if(temp < min)  min = temp;
  }
  return min;
}

int main(){
  int flag,j,i;
  int minlen, same = 0;
  scanf("%d", &n);
  if(n == 0) {  printf("nai"); return 0;}
  getchar();
  for(i = 0; i < n; i++) {
    gets(a[i]);
    //printf("%dfjakfa0\n", i);
    traverse(a[i]);
    //puts(a[i]);
  }

  //while(1);
  minlen = min(n);
  for(i = 0; i < minlen; i++) {
    flag = 0;
    char c = a[0][i];
    for(j = 0; j < n; j++) {
      if(c != a[j][i]){ flag = 1; break;}
    }
    if(!flag)
      same = i+1;
    else break;//这句话没加,导致查第三个点查了好久!!!(如果没加,后面又有都相等的就覆盖掉了)
  }
  if(same == 0){
    printf("nai");
    return 0;
  }
  for(i = same; i > 0; i--){
    printf("%c", a[0][i-1]);
  }

}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值