简单dp-max sum

Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14. 
InputThe first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000). 
OutputFor each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases. 
Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5
Sample Output
 
Case 1:14 1 4Case 2:7 1 6

解题思路:动态规划题,主要的解题思路是递推,不用数组也可以,这里是没有用到数组,利用两个变量curr_max和max-number来标记最大的值,由题意可以知道,序列是有序的,curr_max是当前最大的和,如果是当前的值比要加入的a[i]小,就说明可以从a[i]开始重新找最大的序列和。

AC代码:

#include<iostream>
#include<string.h>
#include<algorithm>
using namespace std;
const int maxn = 100000 + 2;
int T;
int a[maxn];
int main()
{
	scanf("%d", &T);
	int n;
	int t = 1;
	int start, end;
	while (T--)
	{
		scanf("%d", &n);
		int curMax, maxsum;
		for (int i = 1; i <= n; i++)
		{
			scanf("%d", &a[i]);
		}
		curMax = a[1];
		maxsum = a[1];
		int s = 1;
		int e = 1;
		int start = 1;
		int end = 1;
		for (int i = 2; i <= n; i++)
		{
			if (curMax + a[i] >= a[i])
			{
				e = i;
				curMax = curMax + a[i];
			}
			else
			{
				s = i;
				e = i;
				curMax = a[i];
			}
			if (maxsum < curMax)
			{
				start = s;
				end = e;
				maxsum = curMax;
			}
		}
		printf("Case %d:\n", t++);
		printf("%d %d %d\n", maxsum,start,end);
		if (T)
		{
			printf("\n");
		}
	}
	return 0;
}
有问题欢迎私聊~么么哒
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值