PTA甲级1014 Waiting in Line (30分)
1014 Waiting in Line (30分)
Suppose a bank has N windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. The rules for the customers to wait in line are:
- The space inside the yellow line in front of each window is enough to contain a line with M customers. Hence when all the N lines are full, all the customers after (and including) the (N**M+1)st one will have to wait in a line behind the yellow line.
- Each customer will choose the shortest line to wait in when crossing the yellow line. If there are two or more lines with the same length, the customer will always choose the window with the smallest number.
- Customeri will take T**i minutes to have his/her transaction processed.
- The first N customers are assumed to be served at 8:00am.
Now given the processing time of each customer, you are supposed to tell the exact time at which a customer has his/her business done.
For example, suppose that a bank has 2 windows and each window may have 2 custmers waiting inside the yellow line. There are 5 customers waiting with transactions taking 1, 2, 6, 4 and 3 minutes, respectively. At 08:00 in the morning, custome**r1 is served at windo**w1 while custome**r2 is served at windo**w2. Custome**r3 will wait in front of windo**w1 and custome**r4 will wait in front of windo**w2. Custome**r5 will wait behind the yellow line.
At 08:01, custome**r1 is done and custome**r5 enters the line in front of windo**w1 since that line seems shorter now. Custome**r2 will leave at 08:02, custome**r4 at 08:06, custome**r3 at 08:07, and finally custome**r5 at 08:10.
Input Specification:
Each input file contains one test case. Each case starts with a line containing 4 positive integers: N (≤20, number of windows), M (≤10, the maximum capacity of each line inside the yellow line), K (≤1000, number of customers), and Q (≤1000, number of customer queries).
The next line contains K positive integers, which are the processing time of the K customers.
The last line contains Q positive integers, which represent the customers who are asking about the time they can have their transactions done. The customers are numbered from 1 to K.
Output Specification:
For each of the Q customers, print in one line the time at which his/her transaction is finished, in the format HH:MM
where HH
is in [08, 17] and MM
is in [00, 59]. Note that since the bank is closed everyday after 17:00, for those customers who cannot be served before 17:00, you must output Sorry
instead.
Sample Input:
2 2 7 5
1 2 6 4 3 534 2
3 4 5 6 7
Sample Output:
08:07
08:06
08:10
17:00
Sorry
注意的点:只要你去服务的时间(不是计算过后服务的时间)不超过17:00(不包括)就可以输出
理清题意之后,剩下的就是模拟了,我们用队列来模拟窗口,首先把黄线内按照顺寻填满,接着遍历所有窗口,找出服务时间最短的窗口,弹出队列,将新的客人加入队列,以此类推就好
#include <cstdio>
#include <queue>
#include <algorithm>
#include <cstring>
using namespace std;
queue<long long int> Windows[1003];
long long int n,m,k,q;
long long int tim[1003];
long long int ans[1003];
long long int ask[1003];
long long int ltime[1003] = {0};
long long int rtime[1003] = {0};
bool book[1003] = {false};
void input(){
scanf("%lld%lld%lld%lld",&n,&m,&k,&q);
for(int i = 1;i <= k;i++){
scanf("%lld",&tim[i]);
}
}
void work(){
int index = 1;
while(index <= min(k,n * m)){
for(int i = 0;i < n;i++){
Windows[i].push(index);
if(rtime[i] >= 540){
book[index] = true;
}
rtime[i] += tim[index];
ans[index] = rtime[i];
index++;
}
}
for(int i = 0;i < n;i++){
if(Windows[i].size()){
int num = Windows[i].front();
ltime[i] += tim[num];
}
}
while(index <= k){
long long int tag = 0;
for(int i = 0;i < n;i++){
if(ltime[i] < ltime[tag]){
tag = i;
}
}
Windows[tag].pop();
Windows[tag].push(index);
if(rtime[tag] >= 540){
book[index] = true;
}
rtime[tag] += tim[index];
ans[index] = rtime[tag];
long long int num = Windows[tag].front();
ltime[tag] += tim[num];
index++;
}
}
void output(){
for(int i = 0;i < q;i++){
scanf("%lld",&ask[i]);
long long int num = ask[i];
long long int hours = ans[num] / 60;
long long int mins = ans[num] % 60;
hours += 8;
if(book[num]){
printf("Sorry");
}else{
printf("%02lld:%02lld",hours,mins);
}
puts("");
}
}
int main(){
memset(ltime,0,sizeof(ltime));
memset(rtime,0,sizeof(rtime));
input();
work();
output();
return 0;
}