POJ 2387 最短路径模板

    Til the Cows Come Home
    Time Limit: 1000MS

    Memory Limit: 65536K
    Total Submissions: 60567

    Accepted: 20615
    Description
    Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible. 

    Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it. 

    Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.
    Input
    * Line 1: Two integers: T and N 

    * Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.
    Output
    * Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.
    Sample Input
    5 5
    1 2 20
    2 3 30
    3 4 20
    4 5 20
    1 5 100
    Sample Output
    90
    Hint
    INPUT DETAILS: 

    There are five landmarks. 

    OUTPUT DETAILS: 

    Bessie can get home by following trails 4, 3, 2, and 1.
    Source
    USACO 2004 November


    标准的最短路径题,dijkstra 算法的模板

    踩到了两个坑,第一个,两点之间可能有不止一条路,所以要去除重复
    第二个,我一般define MAXINT 喜欢用0x7fffffff  然而,只要这个值再加任意值,就炸了,所以最好还是用10000050 这类的吧
#include<cstdio>
#include<cstring>
#define MAX 1000000
#define MAXN 1005
int map[MAXN][MAXN];
int dis[MAXN];
int visited[MAXN];
void dijkstra(int n)
{
    int k,min;
    for(int i=1;i<=n;i++)
    {
        dis[i]=map[1][i];
        visited[i]=0; 
    }
    for(int i=1;i<=n;i++)
    {
        k=0;
        min=MAX;
        for(int j=1;j<=n;j++)
        {
            if(visited[j]==0&&dis[j]<min)
            {
                min=dis[j];
                k=j;
            }
        }
        visited[k]=1;
        for(int j=1;j<=n;j++)
        {
            if(visited[j]==0&&dis[k]+map[k][j]<dis[j])
                {
                    dis[j]=dis[k]+map[k][j];
                }
        }
    } 
}
int main()
{
    int t,n,a,b,len;
    scanf("%d%d",&t,&n);
    memset(visited,0,sizeof(visited));
    for(int i=1;i<=n;i++)
        for(int j=1;j<=n;j++)
            map[i][j]=MAX; 
    for(int i=1;i<=t;i++)
    {
        scanf("%d%d%d",&a,&b,&len);
        if(len<map[a][b])
        {
            map[a][b]=len;
            map[b][a]=map[a][b];
        }
    }

    dijkstra(n);
    dis[1]=0;
    printf("%d\n",dis[n]);  
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值