Problem G: 字符串删除

Description

定义MyString类,包括:
1. 一个字符数组或字符指针,用于存储字符串内容。
2. void input():读取一个不含空白符的字符串。
3. void output():输出一行字符串。
4. void del(char* str):从当前字符串中删除str中的所有字符。

Input

两个不含空白符的字符串,每个占一行。每个字符串不超过1000个字符。

Output

见样例。

Sample Input

abcdefghijjjkmn
acjk

Sample Output

abcdefghijjjkmn
bdefghimn

HINT


#include <bits/stdc++.h>

using namespace std;

class MyString
{
private :
    char s[10086];
public :
    MyString(){}
    void input()
    {
        cin>>s;
    }
     void output()
     {
         char *p = s;
         while(*p!='\0')
         {
             cout<<*p++;
         }
         cout<<endl;
     }
     void del(char* str)
     {
         while(*str)
         {
             char *p = s;
             while(*p)
             {
                int l = strlen(s);
                for(int i = 0; i < l; i++)
                {
                 if(*str == s[i])
                 {
                     for(int j = i;j < l;j++)
                     s[j] = s[j+1];
                 }
                }
                p++;
             }
            str++;
         }
     }
};


int main()
{
    MyString str;
    char tmp[11];
    str.input();
    str.output();
    cin>>tmp;
    str.del(tmp);
    str.output();
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值