hdu 5090 Game with Pearls 二分图匹配

Problem Description
Tom and Jerry are playing a game with tubes and pearls. The rule of the game is:

  1. Tom and Jerry come up together with a number K.

  2. Tom provides N tubes. Within each tube, there are several pearls. The number of pearls in each tube is at least 1 and at most N.

  3. Jerry puts some more pearls into each tube. The number of pearls put into each tube has to be either 0 or a positive multiple of K. After that Jerry organizes these tubes in the order that the first tube has exact one pearl, the 2nd tube has exact 2 pearls, …, the Nth tube has exact N pearls.

  4. If Jerry succeeds, he wins the game, otherwise Tom wins.

Write a program to determine who wins the game according to a given N, K and initial number of pearls in each tube. If Tom wins the game, output “Tom”, otherwise, output “Jerry”.

Input
The first line contains an integer M (M<=500), then M games follow. For each game, the first line contains 2 integers, N and K (1 <= N <= 100, 1 <= K <= N), and the second line contains N integers presenting the number of pearls in each tube.

Output
For each game, output a line containing either “Tom” or “Jerry”.

Sample Input

2
5 1
1 2 3 4 5
6 2
1 2 3 4 5 5

Sample Output

Jerry
Tom

Source
2014上海全国邀请赛——题目重现(感谢上海大学提供题目)


题意:
初始状态每个tube里有一定的珍珠,
现在只能往tube中添加 a*k 或 0 个珍珠;
其中 k 给定, a ∈ Z;
问最后排列后可不可以使得数目为;
1,2,3…n;


我们只需将每个 tube 的数量的可能情况都列出来
(前提 <=n );
然后进行一次二分图匹配即可;
看最后可不可以完全匹配;

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstdlib>
#include<cstring>
#include<string>
#include<cmath>
#include<map>
#include<set>
#include<vector>
#include<queue>
#include<bitset>
#include<ctime>
#include<deque>
#include<stack>
#include<functional>
#include<sstream>
#include<cctype>
//#pragma GCC optimize("O3")
using namespace std;
#define maxn 200005
#define inf 0x3f3f3f3f
#define INF 0x7fffffff
#define rdint(x) scanf("%d",&x)
#define rdllt(x) scanf("%lld",&x)
typedef long long  ll;
typedef unsigned long long ull;
typedef unsigned int U;
#define ms(x) memset((x),0,sizeof(x))
const int mod = 1e9 + 7;
#define Mod 20100403
#define sq(x) (x)*(x)
#define eps 1e-10
const int N = 1505;

inline int rd() {
	int x = 0;
	char c = getchar();
	bool f = false;
	while (!isdigit(c)) {
		if (c == '-') f = true;
		c = getchar();
	}
	while (isdigit(c)) {
		x = (x << 1) + (x << 3) + (c ^ 48);
		c = getchar();
	}
	return f ? -x : x;
}

ll gcd(ll a, ll b) {
	return b == 0 ? a : gcd(b, a%b);
}
ll sqr(ll x) { return x * x; }

int T;
int n, k;
int vis[2000];
int match[1000];
int G[1000][1000];

bool dfs(int x) {
	for (int i = 1; i <= n; i++) {
		if (G[x][i] && !vis[i]) {
			vis[i] = 1;
			if (!match[i] || dfs(match[i])) {
				match[i] = x; return true;
			}
		}
	}
	return false;
}

int main()
{
	//ios::sync_with_stdio(false);
	rdint(T);
	while (T--) {
		rdint(n); rdint(k);
		ms(vis); ms(match); ms(G);
		for (int i = 1; i <= n; i++) {
			int x; rdint(x);
			while (x <= n) {
				G[x][i] = 1; x += k;
			}
		}
		int full = 0;
		for (int i = 1; i <= n; i++) {
			ms(vis);
			full += dfs(i);
		}
		if (full == n)cout << "Jerry" << endl;
		else cout << "Tom" << endl;
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值