HDU2199Can you solve this equation? (二分经典入门题)

5 篇文章 0 订阅

Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100; 
Now please try your lucky.

Input

The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);

Output

For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.

Sample Input

2
100
-4

Sample Output

1.6152
No solution!

二分经典题目

求导函数,发现函数单调递增。

0-100 二分,Java写注意的是循环结束条件,浮点型难得就是考虑精度问题,精度太高超时,太低答案错误

import java.util.Scanner;

public class Main {
	static int T;
	static double Y;
	static double left=0,right=100;
	static double jisuan(double x){
		return 8*x*x*x*x+7*x*x*x+2*x*x+3*x+6;//不建议用函数,误差太大
	}
	
	static double jisuan1(){//二分
		double left=0;
		double right=100;
		while((right-left)>1e-12){//1e-12可以,其他的可以尝试下,-9之后
			double mid=(left+right)/2;
			if(jisuan(mid)>Y) right=mid;
			else left=mid;
		}
		return left;
	}
	
	public static void main(String[] args) {
		// TODO Auto-generated method stub
		Scanner sc=new Scanner(System.in);
		T=sc.nextInt();
		while(T>0){
			Y=sc.nextDouble();
			if(jisuan(0)>Y||jisuan(100)<Y){//所要求的的答案太小或太大
				System.out.println("No solution!");
			}else{
				double m=jisuan1();
				System.out.println(String.format("%.4f",m));
			}				
			T--;
		}
	}

}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值