hdu-2199Can you solve this equation?(二分)

Can you solve this equation?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 13422    Accepted Submission(s): 5990


Problem Description
Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.
 

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);
 

Output
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.
 

Sample Input
  
  
2 100 -4
 

Sample Output
  
  
1.6152 No solution!
 
解题思路:二分
#include<stdio.h>
double equ(double a)
{
	return 8*a*a*a*a+7*a*a*a+2*a*a+3*a+6;
}
double fabs(double x)
{
	if(x<0)
	return -x;
	else
	return x;
}
int main()
{
	
	int T,i,j;
	double left,right,m,Y;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%lf",&Y);
		left=0;right=100,m=0;
		if(equ(0)>Y||Y>equ(100))
		 printf("No solution!\n");
		else
		{
			while(right-left>1e-10)
			{
			
			if(fabs(equ(m)-Y)<1e-10)
				break;
			else
			{
			m=(right+left)/2.0;	
			if(equ(m)-Y<1e-10) left=m;
			else right=m;
			}	
			}
		 printf("%.4lf\n",m);
		}
		  
		}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

bokzmm

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值