求平面上第K近的点

Problem description:

Given N N N points on the plane. Find the K t h Kth Kth closest point to the origin ( 0 , 0 ) (0,0) (0,0). (Here, the distance between two points on a plane is the Euclidean distance.)

Input:

Line 1: N N N K K K

Others: point coordinate

Output:

Line 1: K t h Kth Kth closest point to the origin ( 0 , 0 ) (0,0) (0,0)

Sample Input 1:

2 1
1 3
-2 2

Sample Output 1:

-2 2

Solution1:

#include <iostream>
#include <cstdio>
#include <cmath>
#include<algorithm>
using namespace std;

struct point{
	long long int x;
	long long int y;
	unsigned long long int distance;
};

bool cmp(point a, point b){
	return a.distance < b.distance;
}

int main() 
{
	int n, k;
	scanf("%d%d",&n, &k);
	const int N=n, K=k;
	
	point points[N];
	
	int i;
	for(i=0; i<N; i++){
		scanf("%lld%lld",&points[i].x, &points[i].y);
		points[i].distance = ((points[i].x)*(points[i].x)) + ((points[i].y)*(points[i].y));
	}
	
	sort(points, points+N, cmp);
	
	cout << points[K-1].x << ' ' << points[K-1].y << endl;
		
	return 0;
}

注意1:

  1. 算法首先求出所有点到 ( 0 , 0 ) (0,0) (0,0)的距离,然后sort排序直接求出距离 ( 0 , 0 ) (0,0) (0,0)第K近的点。
  2. 算法复杂度和空间复杂度较高。
  3. 可通过创建结构体存储点的坐标。
  4. sort函数有三个参数,第三个参数可以制定排序规则。
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值