Identity Card
Do you own an ID card?You must have a identity card number in your family's Household Register. From the ID card you can get specific personal information of everyone. The number has 18 bits,the first 17 bits contain special specially meanings:the first 6 bits represent the region you come from,then comes the next 8 bits which stand for your birthday.What do other 4 bits represent?You can Baidu or Google it.
Here is the codes which represent the region you are in.
However,in your card,maybe only 33 appears,0000 is replaced by other numbers.
Here is Samuel's ID number 331004198910120036 can you tell where he is from?The first 2 numbers tell that he is from Zhengjiang Province,number 19891012 is his birthday date (yy/mm/dd).
Input
Input will contain 2 parts:
A number n in the first line,n here means there is n test cases. For each of the test cases,there is a string of the ID card number.
Output
Based on the table output where he is from and when is his birthday. The format you can refer to the Sample Output.
Sample Input
1
330000198910120036
Sample Output
He/She is from Zhejiang,and his/her birthday is on 10,12,1989 based on the table.
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
int main()
{
int n;
char a[30];
scanf("%d",&n);
while(n--)
{
scanf("%s",a);//仔细审题哦input里a string of the ID,是字符串形式哦
if(a[0]=='3'&&a[1]=='3')//具体题目可知只需要比较前两个字母就好
printf("He/She is from Zhejiang,and his/her birthday is on %c%c,%c%c,%c%c%c%c based on the table.\n",a[10],a[11],a[12],a[13],a[6],a[7],a[8],a[9]);
else if(a[0]=='1'&&a[1]=='1')
printf("He/She is from Beijing,and his/her birthday is on %c%c,%c%c,%c%c%c%c based on the table.\n",a[10],a[11],a[12],a[13],a[6],a[7],a[8],a[9]);
else if(a[0]=='7'&&a[1]=='1')
printf("He/She is from Taiwan,and his/her birthday is on %c%c,%c%c,%c%c%c%c based on the table.\n",a[10],a[11],a[12],a[13],a[6],a[7],a[8],a[9]);
else if(a[0]=='8'&&a[1]=='1')
printf("He/She is from Hong Kong,and his/her birthday is on %c%c,%c%c,%c%c%c%c based on the table.\n",a[10],a[11],a[12],a[13],a[6],a[7],a[8],a[9]);
else if(a[0]=='8'&&a[1]=='2')
printf("He/She is from Macao,and his/her birthday is on %c%c,%c%c,%c%c%c%c based on the table.\n",a[10],a[11],a[12],a[13],a[6],a[7],a[8],a[9]);
else if(a[0]=='5'&&a[1]=='4')
printf("He/She is from Tibet,and his/her birthday is on %c%c,%c%c,%c%c%c%c based on the table.\n",a[10],a[11],a[12],a[13],a[6],a[7],a[8],a[9]);
else if(a[0]=='2'&&a[1]=='1')
printf("He/She is from Liaoning,and his/her birthday is on %c%c,%c%c,%c%c%c%c based on the table.\n",a[10],a[11],a[12],a[13],a[6],a[7],a[8],a[9]);
else if(a[0]=='3'&&a[1]=='1')
printf("He/She is from Shanghai,and his/her birthday is on %c%c,%c%c,%c%c%c%c based on the table.\n",a[10],a[11],a[12],a[13],a[6],a[7],a[8],a[9]);
}
return 0;
}
字符型数组的中已经规定了下标从0开始~要注意哦