数据结构实验之栈与队列四:括号匹配

数据结构实验之栈与队列四:括号匹配

Problem Description

 给你一串字符,不超过50个字符,可能包括括号、数字、字母、标点符号、空格,你的任务是检查这一串字符中的( ) ,[ ],{ }是否匹配。

 

Input

 输入数据有多组,处理到文件结束。

 

Output

 如果匹配就输出“yes”,不匹配输出“no”

 

Example Input
sin(20+10)
{[}]
Example Output
yes
no
------------------------------------------------------------------------------------------------------------------------------
#include<stdio.h>
#include<stdlib.h>

typedef char elemtype;
typedef int status;
#define MAXSIZE 100
#define OVERFLOW -2
#define another 50
#define true 1
#define false 0

typedef struct{
    elemtype *base;
    elemtype *top;
    int stacksize;
}Sqstack;

status isEmpty(Sqstack &S){
    if(S.top == S.base)
        return true;
    else
        return false;
}

elemtype getTop(Sqstack &S){
    if(S.base == S.top)
        return false;
    else
        return *(S.top-1);
}

void initStack(Sqstack &S){
    S.base = new elemtype[MAXSIZE];
    S.top = S.base;
    S.stacksize = MAXSIZE;
}

void Push(Sqstack &S, elemtype e){
    if(S.top-S.base >= S.stacksize){
        S.base = (elemtype *)realloc(S.base,(another+S.stacksize)*sizeof(elemtype));
        S.top = S.base + S.stacksize;
        S.stacksize += another;
    }
    *S.top++ = e;
}

elemtype Pop(Sqstack &S, elemtype &e){
    if(S.top == S.base) return false;
    return e = *--S.top;
}

int LineEdit(Sqstack &S, char str[]){
    int flag;
    for(int i=0;str[i] != '\0';i++){
        if(str[i] == '(' || str[i] == '[' || str[i] == '{'){
            Push(S, str[i]);
        }
        else if(str[i] == ')'){
            if(isEmpty(S)){
                flag = false;break;
            }
            char c = getTop(S);
            if(c == '('){
                Pop(S, c);flag = true;
            }
            else {
                flag = false;break;
            }
        }
        else if(str[i] == ']'){
            if(isEmpty(S)){
                flag = false;break;
            }
            char c = getTop(S);
            if(c == '['){
                Pop(S, c);flag = true;
            }
            else {
                flag = false;break;
            }
        }
        else if(str[i] == '}'){
            if(isEmpty(S)){
                flag = false;break;
            }
            char c = getTop(S);
            if(c == '{'){
                Pop(S, c);flag = true;
            }
            else {
                flag = false;break;
            }
        }
    }
    if(!isEmpty(S)){
        flag = false;
    }
    return flag;
}

int main(){

    char string[123];
    while(gets(string)){
        Sqstack S;
        initStack(S);
        int flag = LineEdit(S, string);
        if(flag == true){
            printf("yes\n");
        }
        else{
            printf("no\n");
        }
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值