洛谷 P3110 [USACO14DEC]驮运Piggy Back ( spfa) 题解

94 篇文章 0 订阅

题目来源:

https://www.luogu.org/problemnew/show/P3110

题目描述:

题目描述

Bessie and her sister Elsie graze in different fields during the day, and in the evening they both want to walk back to the barn to rest. Being clever bovines, they come up with a plan to minimize the total amount of energy they both spend while walking.

Bessie spends B units of energy when walking from a field to an adjacent field, and Elsie spends E units of energy when she walks to an adjacent field. However, if Bessie and Elsie are together in the same field, Bessie can carry Elsie on her shoulders and both can move to an adjacent field while spending only P units of energy (where P might be considerably less than B+E, the amount Bessie and Elsie would have spent individually walking to the adjacent field). If P is very small, the most energy-efficient solution may involve Bessie and Elsie traveling to a common meeting field, then traveling together piggyback for the rest of the journey to the barn. Of course, if P is large, it may still make the most sense for Bessie and Elsie to travel

separately. On a side note, Bessie and Elsie are both unhappy with the term "piggyback", as they don't see why the pigs on the farm should deserve all the credit for this remarkable form of

transportation.

Given B, E, and P, as well as the layout of the farm, please compute the minimum amount of energy required for Bessie and Elsie to reach the barn.

Bessie 和 Elsie在不同的区域放牧,他们希望花费最小的能量返回谷仓。从一个区域走到一个相连区域,Bessie要花费B单位的能量,Elsie要花费E单位的能量。

如果某次他们两走到同一个区域,Bessie 可以背着 Elsie走路,花费P单位的能量走到另外一个相连的区域。当然,存在P>B+E的情况。

相遇后,他们可以一直背着走,也可以独立分开。

输入输出格式

输入格式:

 

INPUT: (file piggyback.in)

The first line of input contains the positive integers B, E, P, N, and M. All of these are at most 40,000. B, E, and P are described above. N is the number of fields in the farm (numbered 1..N, where N >= 3), and M is the number of connections between fields. Bessie and Elsie start in fields 1 and 2, respectively. The barn resides in field N.

The next M lines in the input each describe a connection between a pair of different fields, specified by the integer indices of the two fields. Connections are bi-directional. It is always possible to travel from field 1 to field N, and field 2 to field N, along a series of such connections.

 

输出格式:

 

OUTPUT: (file piggyback.out)

A single integer specifying the minimum amount of energy Bessie and

Elsie collectively need to spend to reach the barn. In the example

shown here, Bessie travels from 1 to 4 and Elsie travels from 2 to 3

to 4. Then, they travel together from 4 to 7 to 8.

 

输入输出样例

输入样例#1: 复制

4 4 5 8 8 
1 4 
2 3 
3 4 
4 7 
2 5 
5 6 
6 8 
7 8 

输出样例#1: 复制

22 

 

解题思路:

       这题就是求两个人到n的最短的距离和,因为每个人走的时长不一样a,b,而且两个人一起走的时候,可能可以花更短的时长p<a+b;一开始想怎么处理一起走的问题,还想过要判断是否为最短路径和交点,后来发现,两个人相遇后一定会一起到终点,因为这一定是最短的,那么我们可以先处理出以p为边权求出n到1-n的dis1【i】最短路,然后在求出A人从1到n的最短路dis2【i】,B人从2到n的最短路dis3【i】,那么我们可以枚举每个点为相遇点,那么ans=min(ans,dis1+dis2+dis3),这样就行了,可以画画图加深理解。。

代码:

#include <iostream>
#include <iomanip>
#include <cstdio>
#include <cstring>
#include <string>
#include <vector>
#include <map>
#include <algorithm>
#include <queue>
#include <stack>
#include <cmath>
#define inf 0x3f3f3f3f
#define ll long long
using namespace std;
const int  maxn=1e5+10;
struct newt
{
    int to,next;
}e[maxn*2];
int fy[3];
int head[maxn],dis[3][maxn],cnt=0,vis[maxn],B,E,P,n,m;
void addedge(int u,int v)
{
    e[cnt].to=v;
    e[cnt].next=head[u];
    head[u]=cnt++;
}
void spfa(int id,int S)
{
    for(int i=1;i<=n;i++)dis[id][i]=inf,vis[i]=0;
    queue<int>q;
    q.push(S);
    vis[S]=1;
    dis[id][S]=0;
    while(!q.empty())
    {
        int now=q.front();
        q.pop();
        vis[now]=0;
        for(int i=head[now];i!=-1;i=e[i].next)
        {
            int v=e[i].to;
            if(dis[id][v]>dis[id][now]+fy[id])
            {
                dis[id][v]=dis[id][now]+fy[id];
                if(vis[v])continue;
                vis[v]=1;q.push(v);
            }
        }
    }
    
}
int main()
{
    scanf("%d%d%d%d%d",&B,&E,&P,&n,&m);
    for(int i=1;i<=n;i++)head[i]=-1;
    for(int i=1,a,b;i<=m;i++)
    {
        scanf("%d%d",&a,&b);
        addedge(a,b);
        addedge(b,a);
    }
    fy[0]=B,fy[1]=E,fy[2]=P;
    spfa(0,1);
    spfa(1,2);
    spfa(2,n);
    int ans=1e9;
    for(int i=1;i<=n;i++)
    {
        ans=min(ans,dis[0][i]+dis[1][i]+dis[2][i]);
    }
    printf("%d\n",ans);
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值