POJ 2955 Brackets(区间dp) 题解

6 篇文章 0 订阅
5 篇文章 0 订阅

题目来源:

http://poj.org/problem?id=2955

题目描述:

Description

We give the following inductive definition of a “regular brackets” sequence:

  • the empty sequence is a regular brackets sequence,
  • if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
  • if a and b are regular brackets sequences, then ab is a regular brackets sequence.
  • no other sequence is a regular brackets sequence

For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1, i2, …, im where 1 ≤ i1 < i2 < … < im ≤ nai1ai2 … aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters ()[, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

<span style="color:#000000">((()))
()()()
([]])
)[)(
([][][)
end</span>

Sample Output

<span style="color:#000000">6
6
4
0
6</span>

解题思路:

     题目大意就是求最大的括号匹配数,一题区间dp的经典题,我们可以设dp【i】【j】为i到j的最大的括号匹配数,枚举长度从小到大,if(s【i】和s【j】匹配)dp【i】【j】=dp【i+1】【j-1】+2;

然后枚举断电dp【i】【j】=max(dp【i】【j】,dp【i】【k】+dp【k+1】【j】);

答案就是dp【1】【n】;

代码:

#include <iostream>
#include <iomanip>
#include <cstdio>
#include <cstring>
#include <string>
#include <vector>
#include <map>
#include <algorithm>
#include <queue>
#include <stack>
#include <cmath>
#define inf 0x3f3f3f3f
#define ll long long
using namespace std;
const int  maxn=1e5+10;
string s;
int len,dp[105][105];
bool pd(char a,char b)
{
	if(a=='('&&b==')')return 1;
	else if(a=='['&&b==']')return 1;
	return 0;
}
int main()
{
	while(cin>>s)
	{
		memset(dp,0,sizeof(dp));
		if(s[0]=='e')break;
		len=s.length();
	//	for(int i=0;i<=len;i++)dp[i][i]=1;
		for(int l=1;l<=len;l++)
		for(int i=0;i<=len-l;i++)
		{
			int j=l+i-1;
			if(pd(s[i],s[j]))dp[i][j]=dp[i+1][j-1]+2;
			for(int k=i;k<j;k++)
				dp[i][j]=max(dp[i][j],dp[i][k]+dp[k+1][j]);
			
		}
		cout<<dp[0][len-1]<<endl;
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值