题解--the empty sequence is a regular

We give the following inductive definition of a “regular brackets” sequence:

  • the empty sequence is a regular brackets sequence,
  • if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
  • if a and b are regular brackets sequences, then ab is a regular brackets sequence.
  • no other sequence is a regular brackets sequence

For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1, i2, …, im where 1 ≤ i1 < i2 < … < im ≤ nai1ai2 … aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters ()[, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

((()))
()()()
([]])
)[)(
([][][)
end

Sample Output

6
6
4
0
6

题意:括号匹配,求最长子串符合匹配规则,子串内有几个元素 。

思路:dp[i][j]表示i到j内的最长符合规则子串。

           全部初始化为零。

           外层由后向前遍历,内层由i 向后遍历,k从i向j 遍历,ps:注意字符串起始位置,以及符号匹配是成对的。

          状态转移方程:

           dp[i][j]=max(dp[i][j],dp[i][k]+dp[k+1][j]);
           if((s[i]=='('&&s[j]==')')||(s[i]=='['&&s[j]==']')){
                  dp[i][j]=max(dp[i][j],dp[i+1][j-1]+2);
            }

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int main(){
    string s;
    while(cin>>s){
        if(s[0]=='e'){
            return 0;
        }
        int dp[105][105]={0};
        int len=s.length();
        for(int i=len-2;i>=0;i--){
            for(int j=i+1;j<=len-1;j++){
                for(int k=i;k<j;k++){
                    dp[i][j]=max(dp[i][j],dp[i][k]+dp[k+1][j]);
                    if((s[i]=='('&&s[j]==')')||(s[i]=='['&&s[j]==']')){
                        dp[i][j]=max(dp[i][j],dp[i+1][j-1]+2);
                    }

                }
            }
        }
        cout<<dp[0][len-1]<<endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值