7-1 根据后序和中序遍历输出先序遍历 (25分) PTA

本题要求根据给定的一棵二叉树的后序遍历和中序遍历结果,输出该树的先序遍历结果。

输入格式:
第一行给出正整数N(≤30),是树中结点的个数。随后两行,每行给出N个整数,分别对应后序遍历和中序遍历结果,数字间以空格分隔。题目保证输入正确对应一棵二叉树。

输出格式:
在一行中输出Preorder: 以及该树的先序遍历结果。数字间有1个空格,行末不得有多余空格。

输入样例:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
输出样例:
Preorder: 4 1 3 2 6 5 7

AC代码

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;

template <class DataType>
struct BiNode
{
 	DataType data;
  	BiNode<DataType> *lchild, *rchild;
  	BiNode(DataType n){
        data=n;
        lchild=NULL;
        rchild=NULL;
  	}
};

template <class DataType>
class BiTree
{
public:
    BiTree()
    {
        int n,i;
        cin>>n;
        int *h,*z;
        h=new int[n];
        z=new int[n];
        for(i=0; i<n; i++)
        {
            cin>>h[i];
        }
        for(i=0; i<n; i++)
        {
            cin>>z[i];
        }
        root = Creat(h,z,n);
    }
  	void PreOrder( ){PreOrder(root);}

private:
  	BiNode<DataType> *Creat(DataType *h,DataType *z,int n);       //构造函数调用
    BiNode<DataType> *root;
    void PreOrder(BiNode<DataType> *bt);                              //指向根结点的头指针

};
int c=0;
template <class DataType>
void BiTree<DataType> :: PreOrder(BiNode<DataType> *bt)
{
	if (bt == nullptr) return;              //递归调用的结束条件
	else {
        if(c==0){
            cout <<"Preorder: "<< bt->data;
            c=1;
		}else{
		    cout <<" "<< bt->data;
		}
             //访问根结点bt的数据域
		PreOrder(bt->lchild);               //前序递归遍历bt的左子树
		PreOrder(bt->rchild);               //前序递归遍历bt的右子树
	}
}

template <class DataType>
BiNode<DataType> *BiTree<DataType> ::Creat(DataType *h,DataType *z,int n){
    if(n==0)
        return NULL;
    int k=0;
    while(h[n-1]!=z[k]){
        k++;
    }
    BiNode<DataType> *t=new BiNode<DataType>(h[n-1]);
    t->lchild=Creat(h,z,k);
    t->rchild=Creat(h+k,z+k+1,n-1-k);
    return t;

}
int main( )
{
	BiTree<int> asd;
    asd.PreOrder();
	return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值