水坑(dfs)

题目链接:http://poj.org/problem?id=2386

 

Description

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. 

Given a diagram of Farmer John's field, determine how many ponds he has.

Input

* Line 1: Two space-separated integers: N and M 

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

Output

* Line 1: The number of ponds in Farmer John's field.

Sample Input

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output

3

 

题目大意:w为水坑,。为陆地,一个w周围8格如果还有w则算连着的水坑,问一张地图上有多少个水坑

 

简单的深度搜索,每找到一个水坑,则将所有与之相连的水坑改成陆地,水坑数目加一,遍历所有的符号,直到没有水坑为止;

 

 

#include<stdio.h>
#include<string.h>
#include<math.h>

#include<queue>
#include<stack>
#include<string>
#include<iostream>
#include<algorithm>
using namespace std;

#define ll long long
#define da    10000000
#define xiao -10000000
#define clean(a,b) memset(a,b,sizeof(a))

char map[110][110];
int n,m;


void dfs(int x,int y)
{
	map[x][y]='.';							//将这个水坑改为陆地 
	int i,j;
	for(i=-1;i<=1;++i)						//遍历上下 
	{
		for(j=-1;j<=1;++j)					//遍历左右 
		{
			int nx=x+i;						//目前的 x轴 
			int ny=y+j;						//目前的 y轴 
			if(nx>=1&&nx<=n&&ny>=1&&ny<=n)	//在地图内 
			{
				if(map[nx][ny]=='W')		//是水坑 
					dfs(nx,ny);				//继续找有没有相邻的水坑 
			}
		}
	}
}

int main()
{
	scanf("%d%d",&n,&m);
	int i,j;
	for(i=1;i<=n;++i)
	{
		for(j=1;j<=m;++j)
			cin>>map[i][j];				//输入地图 
	}
	int sum=0;							//初始水坑数目为0; 
	for(i=1;i<=n;++i)					//遍历地图 x轴 
	{
		for(j=1;j<=n;++j)				//遍历 y轴 
		{
			if(map[i][j]=='W')			//如果是水坑 
			{
				dfs(i,j);				//找到所有与之相连的水坑 
				sum++;					//个数加一 
			}
		}
	}									//遍历完毕 
	printf("%d\n",sum);					//输出 
}

 

 

 

 

 

 

 

 

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值