Largest Rectangle in a Histogram(找面积最大的连续块)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1506

Problem Description
A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles:

Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.
 

Input
The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1 <= n <= 100000. Then follow n integers h1, ..., hn, where 0 <= hi <= 1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.
 

Output
For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.
 

Sample Input
 
 
7 2 1 4 5 1 3 3 4 1000 1000 1000 1000 0
 

Sample Output
 
 
8 4000

题目大意:给一个直方图,然后找到能够构成一个矩形的面积最大的连续的方块,两张图片已经给出来了什么是矩形面积的最大的联通块。

对于每个柱子,找到能够到达的左边最远的地方和右边最远的地方,然后找出最大的面积就行了

ac:


#include<stdio.h>  
#include<string.h>  
#include<math.h>  
  
//#include<map>   
#include<deque>  
#include<queue>  
#include<stack>  
#include<string>  
#include<iostream>  
#include<algorithm>  
using namespace std;  
  
#define ll long long  
#define da    0x3f3f3f3f  
#define xiao -0x3f3f3f3f  
#define clean(a,b) memset(a,b,sizeof(a))// 雷打不动的头文件  

ll Left[100100],Right[100100];
ll shuzu[100100];

int main()
{
	int n;
	while(cin>>n)
	{
		clean(Left,0);
		clean(Right,0);
		clean(shuzu,0);
		if(n==0)
			break;
		int i,j;
		for(i=1;i<=n;++i)
			scanf("%lld",&shuzu[i]);
		//找左边的边界 
		Left[1]=1;//最左边是第一块 
		for(i=2;i<=n;++i)//从第二个开始 
		{
			j=i; //向左查找,如果该值>=当前值,就记录位置并且继续 
			while(j>1&&shuzu[j-1]>=shuzu[i])
				j=Left[j-1];//这里Left中储存的是 第几块 
			Left[i]=j;//最后找到的是能到达的 最左边的距离 
		}
		//同理 右边的边界 
		Right[n]=n;//最右边是第n块 
		for(i=n-1;i>=1;--i)//从n-1开始 
		{
			j=i;//向右查找,如果该值>=当前值,继续 
			while(j<n&&shuzu[j+1]>=shuzu[i])
				j=Right[j+1];//right中是最右边能到达的地方 
			Right[i]=j;//最后找到最右边的距离 
		}
		ll maxx=0;
		for(i=1;i<=n;++i)//遍历;找 所有面积并找最大的 
			maxx=maxx>(Right[i]-Left[i]+1)*shuzu[i]?maxx:(Right[i]-Left[i]+1)*shuzu[i];
		cout<<maxx<<endl;//输出maxx 
	}
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值